Plugin zum Aufspüren von Ungenauigkeiten


Hallo Leute,

für das Problem der Ungenauigkeiten hab ich mal ein kleines Plugin(2015) gebaut, welches
Ungenauigkeiten auch im 10-el-mm-Bereich aufspüren kann.

Zip runterladen, und die Dateien in die enspr. Verzeichnisse der Allplan-Installation kopieren.

1. Starten mit Plugins->ModelInspector
2. zu untersuchende Elemente auswählen
3. es werden 3 Tabellen mit Koordinaten-Werten angezeigt. Das sind immer die
Abstände der x-, y- z-Werte untereinander. (in mm)
Wenn man hier sehr kleine Werte findet ( < 1.0mm) ist es mit Sicherheit eine "ungewollte
Ungenauigkeit"
4. Klick auf einen solchen Wert, zeigt den diesem Wert zugeordneten Punkt
mit einem blauen Punkt (Griff) an. Dann kann man hinzoomen, un nachschauen, was dort an
dieser Stelle falsch ist.

Mit dem Inspektor kann man auch schnell die Attribut-Verteilung checken.
Einfach ein Attribut auswählen, und der Klick auf einen Wert zeichnet die zugeordneten
Elemente rot, und zoomt auf diese.

Gruß Jörg

Anhänge (3)

img
model_inspector.png
Typ: image/png
795-mal heruntergeladen
Größe: 37,39 KiB
Typ: application/zip
593-mal heruntergeladen
Größe: 283,15 KiB
img
attributes.png
Typ: image/png
763-mal heruntergeladen
Größe: 81,39 KiB

Hilfreichste Antwort anzeigen Hilfreichste Antwort verbergen

...oder Nemetschek baut diese nützlichen Plugins einfach in das Programm ein... das wäre das sinnvollste...

Gruß Jürgen
Zeicon 1992-1997 | Allplan 1997-V2019

41 - 50 (61)

..ja, der Optionen-Dialog war seinerzeit der allererste WPF-Dialog in Allplan.
Wenn der dann nicht mehr funktioniert, ist das ein Indiz dafür,
daß etwas mit den WPF-DLL's nicht stimmt.
Die von mir geposteten WPF-DLL's sind die Originalen der Version 2015-1-7.
Leider gehören noch andere dazu, die ich aber hier nicht alle posten kann.

Neuistallation der 2015-1-5 (gibts als Download) sollte das Problem beheben.

Gruß Jörg

hi Jörg,
aber irgendwie hab ich da etwas schiss, die 2015-1-5 auf die 2015 -1-7 neu zu installieren, wer weis was das wieder alles nach sich zieht. Ich habe mir die "WPF-DLL`s vom Laptop und die vom Festrechner je in einen Ordner kopiert und gegenüber gestellt. Absolut das selbe, nur am Laptop funktioniert es.
Walter

binder-cad

Anhänge (1)

img
nemall_wpf.PNG
Typ: image/png
279-mal heruntergeladen
Größe: 354,06 KiB

Hallo Walter,

zu den "WPF-DLL's" gehören insbesondere:

NemAll_DialogFramework.dll
NemAll_WPFDialogsInterop.dll
NemAll_WPFControls.dll
NemAll_WPFStyles.dll
NemAll_WPFLibrary.dll

..die anderen sind eher für Allplan wichtig, und nicht so sehr für's Plugin.

Die zum Crash-Zeitpunkt geladenen DLL's mit deren Versions-Nummern findet man in Crash.xml
des Crash-Reports.

Gruß Jörg

hallo Jörg,
habs nun doch gewagt mit der Neu-Installation bin nun auf der 2015-1-5. Auch hier wieder deine letzte Version vom ModelInspektor in Menü und Prg eingefügt, trotzdem Absturz. War allerdings wieder eine lehrreiche Lektion. Nun hab ich auch schon was vom Crash-Report mitgekriegt und vom Herrn Fuhrman gelernt das man diese Dateien über "%temp%" Starteingabefeld von Windows einsehen kann. Mit den Jahren kann das noch richtig gut werden.
nette Grüße
Walter
anbei noch der crach.xml Report

binder-cad

Anhänge (1)

Typ: application/pdf
642-mal heruntergeladen
Größe: 681,34 KiB

Hallo Walter,

bitte nochmal die installierte .NET-Framework-Version checken.
Es sollte mind. 4.5 sein, besser noch 4.5.2.

Und Du schreibst:
"Ich habe meine "*.bak" wieder umbenannt. Jetzt gehts auch wieder."
Damit ist doch bewiesen, daß die umbenannten und die "reinkopierten"
DLL's nicht identisch sind!
Könntest Du mal die Daten (Datum und ggf. Versionen) der DLL's vergleichen.
Da muss es einen Unterschied geben!

Die von mir übermittelten DLL's stammen aus meiner frisch installierten
Allplan-Version 2015-1-7. Insofern darf es eigentlci hnicht sein, daß hier Unterschiede bestehen.

Gruß Jörg

Hallo Nemo,
die Dll`s meiner beiden Rechner hatte ich verglichen 112 Elemente Datum und bit absolut identisch.
.Net-Framework-Version ist 4.5.2 obwohl vorhanden nochmal neu installiert.
allplan vers. 2015-1-5 habe ich neu über die 2015-1-7 installiert.
hat alles nichts gebracht.
aber was jetzt dazu kommt wenn ich allplan aufrufe weist er mich auf das update 2015-1-7 hin, und bei dieser Installtion bricht er ab "wähend der Installation des Updates sind Fehler aufgetreten".
Walter
muß mich nochmal korrigieren, nach cleanstd und cleanreg hat nun die Installation von update 2015-1-7 doch funktioniert, jedoch immer noch Absturz beim ModelInspektor.

binder-cad

Anhänge (1)

img
Update.PNG
Typ: image/png
258-mal heruntergeladen
Größe: 75,85 KiB

Hallo Walter,

bitte mal die von mir geposteten DLL'mit den im PRG vorhandenen (temporär umbenannten)
DLL's vergleichen.
Wenn du sagst, nach dem reinkopieren "meiner" DLL's geht der Optionen-Dialog nicht mehr,
muss es doch Unterschiede in diesen Dateien geben!

Gruß Jörg

hallo Nemo,
anbei gegenüberstellung deiner und meiner dll`s, bis auf Datum sehen diese gleich aus.
Habe nochmal meine entfernt und deine reinkopiert, Absturz bei "Optionen" und bei ModelInspektor.
Meine wieder eingesetzt, Absturz nur noch bei ModelInspektor.
Wie gesagt .Net-Framework 4.5.2 und allplan 2015.1.5 neu installiert und auf 2015.1.7 upgedated.
Ich freu mich das sonst noch alles geht muß aber nun wieder etwas arbeiten.

nette Grüße
Walter

binder-cad

Anhänge (1)

img
gegenüberstellung.PNG
Typ: image/png
245-mal heruntergeladen
Größe: 133,87 KiB

-Gestartet wird dann über "Plugins"- wie funktioniert das? Habe bis jetzt noch nie mit Plugins gearbeitet. Finde auch nichts in der Hilfe!
Viktor

Hallo,

hier das Plugin "Modelinspector" für 2016.

Gruß Jörg

Anhänge (1)

Typ: application/zip
336-mal heruntergeladen
Größe: 325,70 KiB
41 - 50 (61)

Verwendung von Cookies:
Um die Webseite optimal gestalten und fortlaufend verbessern zu können, verwendet Allplan Cookies.
Durch die weitere Nutzung der Webseite erklären Sie sich mit der Verwendung von Cookies einverstanden.  -  Mehr Informationen

Schließen