[Frage] Fehler Filtererstellung Report Türliste in Visual Studio 2022 [Gelöst]


Hi,

ich versuche krampfhaft eine Filterfunktion für die Gewerke meiner Türliste zu erstellen. Dafür gibt es praktischer Weise eine Anleitung aus dem Jahr 2014 von Allplan (siehe Anlage). Allerdings sobald ich folgende Eintragung vornehme:

<ReportParameter Name="Gewerk">
<DataType>String</DataType>
<AllowBlank>true</AllowBlank>
<Prompt>Distinct(Fields!T_Gewerk.Value)</Prompt>
<MultiValue>true</MultiValue>
</ReportParameter>

wertet der Report nichts mehr aus. Was mache ich hier falsch? Die Vorgehensweise habe ich exakt eingehalten. Anbei mal die geänderte Reportdatei. Ich hoffe Ihr könnt mir helfen.

LG Micha

Anhänge (2)

Typ: image/jpeg
72-mal heruntergeladen
Größe: 128,58 KiB
Typ: application/x-rar
368-mal heruntergeladen
Größe: 9,16 KiB

Lösung anzeigen Lösung verbergen

Hi MichaelGoehlert,

Can you open the report as text and check the yellow part(snap1.jpg)?

You can watch how it's done at the link below.
https://www.youtube.com/watch?v=PKeKMnXI7i8

Hatem OZDEMIR
Architect | Allplan Trainer | BIM Manager
Website: http://www.mimcad.com
Website: http://www.bimakademi.com
e-mail: hatemozdemir[at]gmail.com
Ankara / Turkiye
LinkedIn-Profil
YouTube

Anhänge (3)

Typ: image/jpeg
34-mal heruntergeladen
Größe: 56,89 KiB
Typ: image/jpeg
24-mal heruntergeladen
Größe: 79,86 KiB
Typ: image/jpeg
12-mal heruntergeladen
Größe: 81,98 KiB

Hi,

After adding the filter Parameter in visual studio (There may be a problem when you do it with copy paste), it is necessary to match the filter with the table

Hatem OZDEMIR
Architect | Allplan Trainer | BIM Manager
Website: http://www.mimcad.com
Website: http://www.bimakademi.com
e-mail: hatemozdemir[at]gmail.com
Ankara / Turkiye
LinkedIn-Profil
YouTube

Anhänge (1)

Typ: image/jpeg
95-mal heruntergeladen
Größe: 467,24 KiB

Hi Hatem,

I let the copy and paste be and create the parameter (1) new (just like you). Then I add the filter in the details group (2) and at last I add the filter over the whole table (3). But when I lauch the report in Allplan no values are listed und there are no values in the menue (Gewerke) selectable. Maybe there is a problem with the Parameter (1). Which parameter adjustments should i make?

Anhänge (2)

Typ: image/jpeg
56-mal heruntergeladen
Größe: 228,91 KiB
Typ: image/jpeg
30-mal heruntergeladen
Größe: 259,40 KiB

Hi MichaelGoehlert,

Can you open the report as text and check the yellow part(snap1.jpg)?

You can watch how it's done at the link below.
https://www.youtube.com/watch?v=PKeKMnXI7i8

Hatem OZDEMIR
Architect | Allplan Trainer | BIM Manager
Website: http://www.mimcad.com
Website: http://www.bimakademi.com
e-mail: hatemozdemir[at]gmail.com
Ankara / Turkiye
LinkedIn-Profil
YouTube

Anhänge (3)

Typ: image/jpeg
34-mal heruntergeladen
Größe: 56,89 KiB
Typ: image/jpeg
24-mal heruntergeladen
Größe: 79,86 KiB
Typ: image/jpeg
12-mal heruntergeladen
Größe: 81,98 KiB

Hi Hatem,

this is the solution! Thank you very much!


Verwendung von Cookies:
Um die Webseite optimal gestalten und fortlaufend verbessern zu können, verwendet Allplan Cookies.
Durch die weitere Nutzung der Webseite erklären Sie sich mit der Verwendung von Cookies einverstanden.  -  Mehr Informationen

Schließen