[Frage] Allplan 2021-0-3 VS .pypsub konnte wegen falscher Versionsnummer nicht gelesen werden.


Guten Tag,

Ich habe mich schon etwas mit den Python-Parts sowie mit Visual-Scripting auseinandergesetzt und bin nun beim Versionswechsel auf ein Problem gestoßen.

Die Scripte wurden in Allplan 2020 erstellt und das erste mal getestet/genutzt.
Nach dem Update auf Allplan 2021 gibt der VS-Trace die Fehlermeldung aus, dass die pypsub Datei nicht gelesen werden konnte.
Als Begründung wird eine falsche Version des Scripts genannt.

Die Datei "NodeBlank.pypsub" wird jedoch richtig erkannt und kann in VS verwendet werden.
Im Code habe ich keinen Unterschied feststellen können.
Auch das Ändern der Version im Code von 1.0 auf 1.1 oder 2.0 hat nichts am Fehler geändert.

Die Fehlerausgabe sowie die beiden Scripte habe ich Angehängt.

Gruß
Joseph

Anhänge (3)

img
VS-Trace_01.PNG
Typ: image/png
29-mal heruntergeladen
Größe: 64,07 KiB
img
NodeBlank_Screen_01.PNG
Typ: image/png
18-mal heruntergeladen
Größe: 45,54 KiB
img
NodeGetColumn_Screen.PNG
Typ: image/png
11-mal heruntergeladen
Größe: 33,98 KiB
1 - 2 (2)
  • 1

Hallo Joseph,

nach Absprach mit DEV-Team liegt das Problem daran, dass der Name von eigenen Nodes einen Unterstrich "_" hat. Die Versionskontrolle in VS hat momentan die Schwierigkeit den Unterstrich richtig zu verarbeiten. Als Workaround würde ich vorschlagen den Unterstrich "_" durch den Bindestrich "-" zu ersetzen.

Wir werden aber dann diese Problem fixen.

VG
Xinling

1 - 2 (2)
  • 1

Verwendung von Cookies:
Um die Webseite optimal gestalten und fortlaufend verbessern zu können, verwendet Allplan Cookies.
Durch die weitere Nutzung der Webseite erklären Sie sich mit der Verwendung von Cookies einverstanden.  -  Mehr Informationen

Schließen