[Question] LIBRARY VERSION MISMATCH


Hello! I am new to Allplan and what I do is creating Smartparts. I created an object and set buttons from which you can change the surface materials, the same as in a built-in Smartpart in Allplan. From one moment on these buttons stopped working well both in case of my object and in case of built-in Smartpart. When I push them a pop-up browsing menu doesn't appear and I have to use the escape button so that I can continue working on the program. In the Trace Allplan window the following message appears:

!!! LiteDB : LIBRARY VERSION MISMATCH. Expected Version by SQLITE_VERSION_NUMBER is 3007013. Found version by sqlite3_libversion_number() is 3015000 !!!

The surfaces I set at first are located in the Design folder of my project and they are SURF Files. They are actually visualized in the 3D window of Allplan, but I cannot change them or find them in a browsing window inside Allplan.
Can anyone help, please?

1 - 3 (3)
  • 1

With 'Allplan Trace' running, I get the same error message when double-clicking on a simple text-element or dimension line etc.! This is extremly slowing down our workflow! What is the reason for this? A few versions earlier (current 2018-1-5), we didn't have this sort of problem. I expect the Allplan-Support to fix this bug/problem with the next version. Thank you!

we have same problem with version mismatch, and in my tracing window is full of @interpreter succeed@ string. This string appears many times particalary each action.
Allplan 2018-1-5

1 - 3 (3)
  • 1

https://campus.allplan.com/ uses cookies  -  More information

Accept