Search Result

11 - 20 (21)
Version:  Allplan 2019 / Allplan 2018 / Allplan 2017 / Allplan 2016 / Allplan 2015 / Allplan 2014 / Allplan 2013 / Allplan 2012  | Last modified: 22.08.2019
1 user(s) found this FAQ helpful

Task:

You have installed Allplan on several local workstations. Now you want to change the installation so that you can access a common network drive.



Note:

Before you switch to a network installation, it is essential that you back up all the data of all the workstations.
We strongly recommend that you take advantage of the expertise of Nemetschek’s technical support staff. We are happy to help you!



Solution:

The following description shows how to change several workstations where Allplan is installed locally and the project data is also stored locally on each computer to workstations with a common network drive without Workgroup Manager.

1st - getting ready
Choose one of the workstations where you will install all the projects and the office standard (hereinafter referred to as the main workstation).
First, move all the projects to the main workstation.

1.a: copying resources into projects
To make sure that the projects in your office have a uniform appearance, change the path settings for the projects' resources to 'Project'.
Make the following setting for each project:
Allplan -> File menu -> ProjectPilot - Admin -> select the individual projects one after the other -> right mouse button -> Properties -> Settings tab
Set the path settings for 'Pen and line definitions', 'Fonts', 'Patterns, hatching styles, area styles', 'Bar and mesh cross-section catalogs', 'Layer structures, line styles, drawing types' and 'Attributes proposed' from 'Office' to 'Project', if necessary.
The corresponding elements are copied from the office standard directly to the project. This ensures that the project settings stay the same even when you copy the project to the new server with the new office standard.

1.b: same folder name as project name
Open the 'General' tab and select the 'Same folder name as project name' setting if you want to proceed as described in 2b.

1.c: pen color ("Color stands for pen")
The pen color for the "Color stands for pen" setting is a user-specific setting that is not saved in the project but in the user folder (...\Usr).

2.a: backing up projects of the individual workstations and importing them to the main workstation (recommended method):
Back up the individual projects. To do this, open the Services application and select Data Backup -> Create -> Entire folders -> Projects.
You can back up several projects in a single operation.
Before you start, specify the backup folder on the network or on the local hard disk: Services application -> Configuration -> Backup path ->Browse for Folder.

The next step is to import the saved projects to the main workstation.To do this, open theServices application -> Data Backup -> Import -> Projects Before you import the individual projects, you can create new Allplan projects at the main computer. As an alternative, you can also create a new project during the import.

2.b: backing up projects of the individual workstations and importing them to the main workstation (special approach):
This approach should only be used with good reason for exceptional cases as it requires in-depth knowledge of Windows.
With this method, Windows Explorer is used to import the projects to the main workstation.
If some project names exist twice, you need to rename these projects before you back them up.

You can then rename the existing 'project.dat' file in the Prj folder of the main workstation.
Next, select the Services application -> Service -> Hotline Tools -> reorg -> Restore project management file.
The system creates a new project administration file (project.dat), which should list all projects with names.

Now the main workstation contains the latest version of all the projects of the office.

3rd - merging project defaults
Open ProjectPilot at the individual workstations and copy the elements you want to transfer (symbols, smart symbols, lists, schedules, and so on) to the external path. Of course, you can set the external path to a common network folder that can be accessed by all workstations.
Next, open ProjectPilot at the main workstation and copy the contents of the external path to the office standard.

4th - data backup

  • Back up the projects, office standard and user settings at the main workstation:
    You can also copy the ..\prj (projects), ..\std (office standard) and ..\usr (user folder) paths to a backup folder (Nemsic, for example) on the hard disk.
  • In addition, you need to back up the ..\usr\local folder at every stand-alone computer.
  • Export the user interface setting of each user to a file: Allplan -> Tools - > Customize .... -> Export...


5th - uninstalling
Remove Allplan from all workstations.

6th - reinstalling
Before you install the same version again, create and share a folder (Nemdata, for example) on the future data server. Create a subfolder - Allplan - in this folder.

The next step is to reinstall the same version on all the workstations.

Specify the following installation paths:
Program folder:
local (C:\Programs\Nemetschek\Allplan, for example)
Central file storage folder:
Browse -> Network...
Find the sharedNemdata folder and select the Allplan folder.

After this, start installing.

7th - testing the start and restoring the backup
After the installation (check whether Allplan starts), copy the ..\prj and ..\std folders you backed up from the main workstation to the new ...\Nemdata\Allplan server folder.

Next, use Windows Explorer to copy the contents of the former user folder (…\usr\local) of the stand-alone workstation to the new user folder of the computer you just installed.

8th - updating the project administration file
Go to the project.datfile in the ...\Nemdata\Allplan\Prjfolder and rename itproject.alt.After this, do the following:
Services application -> Service -> Hotline Tools -> reorg -> Restore project management file.

9th - summary
Now all the workstations access a common network drive with the same project pool and office standard.
With this type of installation, only one user can access a project at any one time. If several users are to work on a project at the same time, you need to install Workgroup Manager.

Download PDF  FAQ_EN_Switching_from_single_installation_to_network...
Version:  Allplan  | Last modified: 07.07.2017
Not voted yet. Be the first to vote this FAQ as helpful!

Question:

How can I access the FTP server of technical support?



Answer:

You can download data from and upload data to the FTP server.

To access our FTP server, you require a current Windows operating system. Do the following:

Please enter the following address in Windows Explorer (do not use Internet Explorer!):

ftp://nemhotline:ha37jvg8f@ftp.nemetschek.de


1. Downloading data:
You can find our data in the /Download folder.
Right-click the folder(s) or file(s) you want to download and select "Save Target As ...".
Specify where you want to copy the data by selecting a folder on your computer.

If customers agree, we can provide customer-specific data in the /Customerfolder.
For this, you will get separate instructions.


2. Uploading customer data:
If we agree, customers can upload data to the /Upload folder.



Notes:

  • You can upload only files. You cannot upload folders to the server. If you want to upload an entire project, please save this project to a ZIP file first.
  • You can also use Internet browsers to access the FTP server. However, there are some restrictions. Use an FTP client program (for example, FileZilla)to avoid errors. This makes it easier for you to upload and download data. See the following information.
  • Login details for FTP program:
    Address:
    ftp.nemetschek.de
    Login:
    nemhotline
    Password:
    ha37jvg8f
Download PDF  FAQ_EN_Data_on_FTP_server_.pdf
Version:  Allplan 2020 / Allplan 2019 / Allplan 2018 / Allplan 2017 / Allplan 2016  | Last modified: 23.09.2019
Not voted yet. Be the first to vote this FAQ as helpful!

Question:
I purchased a new license and received a Product Key for Allplan. However, I work with an earlier Allplan version. How can I install and license Allplan 2015 or an earlier version despite the new license?


Answer:

Allplan 2016 introduced a new protection system. Since then licensing has been based on CodeMeter by Wibu Systems AG. You can no longer use Softlock (NemSLock) or hardlocks with Allplan. For running Allplan, you get a Product Key by email. Using this key, you can activate your license online.

This new license is not downward compatible. Consequently, you cannot use it for earlier Allplan versions.

For licensing earlier versions, you require the Client ID and CD Key. You can find this information in the delivery note or invoice. Instead of a temporary license, use the appropriate trial license to install Allplan 2015 or an earlier version. Then generate a registration request to license and activate the modules you purchased.

Note:
If you use a license server for which you purchased an additional license, please read the separate document or contact support.de@allplan.com. We will show you how to add the new license to the license server.

If you want to install Allplan 2015 or an earlier version, use a trial license to install the version you need.

Downloading Allplan:
Make sure the Allplan version you install is always up-to-date. In other words, it should include the latest hotfixes and service releases.
You can download the current Allplan version from Allplan Connect or the FTP server.
Allplan Connect:
https://connect.allplan.com/de/support/downloads.html


1. Install Allplan with a trial license
Install Allplan. In the 'Select License Information' dialog box, choose 'Trial license for temporary use' and select the license for 'Architecture' or 'Engineering'.

Important: If you work with Workgroup Manager, select 'Different trial license' -> 'Next'. Open the Workgroup folder for your country and select the appropriate license. Then follow the instructions and install Allplan. Make sure you enter the paths correctly.


2. Request a license registered for your computer
The trial license is valid for 30 days. It is not personalized.
Consequently, you have to enter your personal data manually when generating the registration request.
You can find the required Client ID and CD Key in the delivery note or invoice.

To generate a registration request, do the following:

Open the License Manager (Service application -> Utilities- > License -> License Manager).
Select the license entry for your seat and click 'Request license'. Please follow the instructions displayed on screen.

Note: Editing customer details requires administrator privileges. The system will issue an appropriate message. Close NemSLock License Manager and start the Services application again. To do this, click the Services desktop icon with the right mouse button and select 'Run as administrator' on the shortcut menu.


Enter the necessary details:
The Client IDhas eight zeros (00000000) and the CD Keyhas eight capital F's (FFFFFFFF).

For the Client ID, enter your customer number. You can find your customer number in the letteror delivery notethat came with Allplan.
For the CD Key, enter your CD Key, which you can also find in the letter or delivery note. Make sure you use small letters and capital letters accordingly.

Note:You can find the Client ID and CD Key at top left in the delivery note. The CD Keyusually consists of the numbers 0 to 9 and the capital letters A to F.


Fill out all the fields. Make sure you enter your email address correctly, because registered licenses and replies to status queries of license will be sent to the address you specify here.
Click Next >

For the seat, change the number 94 to the license you purchased, for example, 02, 03 or 04.
Specify how to send the registration file and click Next >.

Start email program ...
The program creates and saves the register.txt file before it opens your default email program. The program automatically attaches the registration file to the email and enters register (please no spam) @ (please no spam) nemetschek.defor the address.

Save the registration file ...
The program creates and saves the register.txt file before it opens the folder with the registration file in Windows Explorer. Now you can use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer with Internet access and so on.

In addition, you can see the data that were written to the registration file.

  1. Click Finish.
  2. Click Close to exit NemSLock License Manager.

You will receive a reply by email within a few minutes. This email provides information on the registration process and usually includes the registered license file.

Note: The registered license file is generated by an automated system. Consequently, any additional comments in incoming emails are not read.


3. Installing the license file
Shortly after we received the registration request, we will send you the final license file to the email address you specified in the registration request.
Install this license file as follows:

  • Save the license file to any folder on the hard disk.
    If the license comes as a zip file, extract it.
  • Next, install the license by double-clicking the license file ("customer#_seat.nslock").
    Confirm the dialog box.
  • As an alternative, you can also use License Manager to install the license file (Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager).
    Click "Install - Install license" and then "Browse..." to select the license.
    Click "Finish" to complete the installation process.
  • Your registered license is displayed in the License Manager. Clear the check box for the trial license (for example, seat 94 or 98). Make sure your registered license is the only license that is selected.




Download PDF  FAQ_EN_Installing_an_earlier_version_with_NemSLock_i...
Version:  Allplan 2015 / Allplan 2014 / Allplan 2013  | Last modified: 17.12.2015
Not voted yet. Be the first to vote this FAQ as helpful!

Question:

How can I move NemSLock Server to a new server?



Answer:

Reinstalling NemSLock Server

  • Select one of the temporary license files for NemSLock server (for example, 1234567a_001_psd.nslsrv). These licenses are valid for 30 days. However, each license includes only one seat of each configuration purchased. The full number of seats purchased will be available to you as soon as you have installed the registered licenses (see below). If you purchased a configuration for one seat only, you will, of course, receive only one temporary license.
  • When you opt for the “Custom” setup type, you can choose between the following program features:
    Console
    You can use this program to administer NemSLock Server. The console can be installed on several workstations. This way, you can administer the server from a number of different locations. However, you can only connect one console to the server at any one time.
    Server
    The actual license server.
    Logviewer
    This tool analyzes the log files of NemSLock Server.
    User List Generator
    You can use this tool to create the users for NemSLock Server from a text file or based on a server.
    By default, Setup installs all these features.
  • If your license includes configurations for several seats, you need to install the additional temporary license files for NemSLock server after the installation (see below).


Transferring the user administration from the old server (if users are available)

  • You can find the user administration in the program folder of the license server. Copy the "users.mcf" file to the program folder of the new license server.
  • Stop the license server service on the new server before you copy the file. To do this, start the "stopService.bat" program, which is also in the program folder of the license server.
  • After copying, start the license server service again. To do this, use the "startService.bat" program.


Returning the registered licenses

  • Open NemSLock 2006 Server Console on the old server by clicking the icon on the desktop or Start -> (All) Programs -> NemSLock 2006 Server -> NemSLock 2006 Server Console.
  • Click "Stop server".
  • Click "Modules".
  • Click "Transfer license permanently".
  • Confirm the following dialog boxes. Click “Browse”.Windows Explorer starts and opens the folder with the hcws-format file. Now you can use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer with Internet access and so on.Send this file by email to register@nemetschek.de.
  • We will send you an email, confirming that we have received the licenses.
  • You always have to return all licenses.
  • After you have done this, they are only valid for two more days.


Registering the license(s) on the new server

  • Open NemSLock 2006 Server Console on the new license server.
  • Click "Modules" on the left.
  • Select the seat you want to register. If your license contains configurations for several seats, read the notes further down.
  • Click "Registration request (register.txt)".
  • Click "Edit".
  • Fill out all fields marked with an asterisk (*). Make sure you enter your email address correctly, because the registered license file will be sent to this address (and not to the address of the person who sent the registration request!). Click OK to confirm.
  • Click "Create registration request".Windows Explorer starts and opens the folder with the "register.txt" file. Now you can use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer with Internet access and so on.Send the registration request by email to register@nemetschek.de.


If your license includes configurations for several seats, you must send a separate registration request for each seat. You will then receive a registered license file for each seat. You must install each file.

How to install licenses

  • Open NemSLock 2006 Server Console.
  • Click "Stop server" on the left.
  • Click "Modules" on the left.
  • Click ”Browse” to navigate to the registered license file.
  • Click "Install license file".
  • After this, you can start the server again by clicking "Start server".


Configuring the clients

  • Now you need to change each client to the new license server.
  • Click Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager.
  • If the license server window is hidden, click "Configure NemSLock Server"at the bottom. It is a good idea to lock this window. All you need to do is click the drawing pin icon.
  • Enter the computer name or IP address of the license server in the empty box. Then click the "Update” icon to the right.
  • Now the user can select one of the seats provided. Click "Close" to complete the configuration. Now you can start Allplan.
  • After having successfully connected to the license server, clear the check boxes for the trial licenses in the area at the top.


Notes:

  • If a user selects several configurations for a seat and starts Allplan, the license server will provide the required licenses; in other words, starting Allplan once might require two licenses. Consequently, fewer licenses are available to other users.
  • 2014-1 and later: If the latest version of License Manager is installed (file version 1. 0. 26. 153 or later, see License Manager- Options- System), you can also select several licenses. If one of the selected licenses is currently being used by someone else, the program will automatically select the next available license.
  • Clients communicate with the server by TCP/IP via port 10977. So you need to configure the firewall accordingly.
  • The license server and the licenses are downward compatible; they can be used in conjunction with older Allplan versions.
Download PDF  FAQ_EN_Moving_NemSLock_Server_to_a_new_server.pdf ...
Version:  Allplan 2015 / Allplan 2014 / Allplan 2013 / Allplan 2012 / Allplan 2011  | Last modified: 08.05.2019
2 user(s) found this FAQ helpful

Question:

I have installed Allplan using the temporary Softlock license ("customer#_seat_psd.nslock") and "Trial" is displayed for its status in the License Manager.
How can I register this license?



Answer:

You use License Manager to create a registration request and send it by email to register@nemetschek.de.
In response, you get a final license file. Installing this license removes the lime limit.
Below is a description of the necessary steps.



Notes:

  • Using the temporary license, you can start Allplan as a trial version. You can work with Allplan without any restrictions for 30 days.
    After expiration of this period, Allplan starts as a viewer only. However, you can still request and install the final license.
  • When running Windows Vista, start Nemetschek License Manager as the administrator:
    Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager
    Click "License Manager" with the right mouse button and choose "Run as administrator" on the shortcut menu.




How to proceed:

1. Request a license registered for your computer

  1. On the Windows taskbar, click Start - (All) Programs - Nemetschek - Nemetschek Softlock 2006 - License Manager(or Services application -> Utilities -> License -> License Manager (NemSLock)).

    When running Windows Vista, start License Manager as the system administrator: click Start - (All) Programs - Nemetschek - Nemetschek Softlock 2006 - License Manager.
    Click License Managerwith the right mouse button. On the shortcut menu, click Run as administrator.
  2. Select the seat you want to register so that it is highlighted in blue.

    Note:You can only register seats you have purchased. If you can see only seats with numbers between 90 and 99 (= trial licenses for temporary use), you first need to install the personal license for temporary use.
  3. Click License requestat top left.

    The License Request Wizardstarts. The Welcome to the license request wizarddialog box provides information on the steps that follow.
  4. Click Next >.
    The Customer detailsdialog box opens.

    Note: Editing customer details requires administrator privileges. If you do not have these privileges, you will see a corresponding message. Cancel NemSLock License Manager and start again by selecting the Run as administrator option on the shortcut menu.
  5. Enter the necessary details:

    - If the Client IDhas eight zeros (00000000) and the CD Keyhas eight capital F's (FFFFFFFF), you selected the Trial license for temporary useoption when you installed Allplan.
    In this case, install the personal license for temporary use before you create the registration request.

    - If Client IDand CD Keydo not match the numbers printed on your delivery note (for example, typing errors, small letters and capital letters mixed up), you can enter Client ID and CD Key manually.

    - Fill out all the fields.

    Make sure you enter your email address correctly, because registered licenses and replies to status queries of license will be sent to the address you specify here.

    Note:Check the entries for Client ID(customer number) and CD Key , making sure these numbers are the same as those printed on the delivery note you received from Allplan. The CD Keyusually consists of the numbers 0 to 9 and the capital letters A to F.

    Tip: You can also find these numbers in the personal license file for temporary use (*_psd.nslock). Open the license file in an editor and scroll down to the end of the file. You can then copy the license codes displayed after CUSTOMERand CDKEYto the Clipboard and paste them into the appropriate boxes.
  6. Click Next >.
  7. Select the Program, Versionand Seatand click Next >.

    Note: If the Client IDis invalid (for example, when you use a trial license) you cannot confirm the dialog box by clicking OK. Instead, you will see a corresponding message.
  8. Specify how to send the registration file and click Next >.

    Start email program ...
    The program creates and saves the register.txt file before it opens your default email program. The program automatically attaches the registration file to the email and enters register (please no spam) @ (please no spam) nemetschek.defor the address.

    Save the registration file ...
    The program creates and saves the register.txt file before it opens the folder with the registration file in Windows Explorer. Now you can use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer with Internet access and so on.

    In addition, you can see the data that were written to the registration file.
  9. Click Finish.
  10. Click Close to exit NemSLock License Manager.


You will receive a reply by email within a few minutes. This email provides information on the registration process and usually includes the registered license file.

Note: The registered license file is generated by an automated system. Consequently, any additional comments in incoming emails are not read. If you have any questions or need more information, please contact Allplan directly.



2. Install the license file

Shortly after you sent the registration request to 'register@nemetschek.de' as described in step 1, the final license file will be sent to the email address you specified in the registration request.
Install this license file as follows:

  • Save the license file to any folder on the hard disk.
    If the license comes as a zip file, extract it.
  • Next, install the license file by double-clicking it ("customer#_seat.nslock").
    Confirm the dialog box.
  • As an alternative, you can also use License Manager to install the license file (Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager).
    Click "Install - Install license" at top left in Nemetschek SoftLock License Manager and select the license by clicking "Browse...".
    Click "Finish" to complete the installation process.


Note:

Do not use the same computer to register several license files for different seats. This would connect the seats. You cannot separate the seats again without the help of technical support.

Download PDF  FAQ_EN_Nemetschek_Softlock_-_first_steps.pdf
Version:  Allplan 2015 / Allplan 2014 / Allplan 2013  | Last modified: 14.02.2019
Not voted yet. Be the first to vote this FAQ as helpful!

Question:

Allplan starts as a viewer. What can I do?



Answer:

Do the following:

1. The Allplan license folder contains the servcfg.nse file.

Open this folder:
Services application -> Service -> Windows Explorer -> General program data (ETC, LIC) -> License.

Delete the servcfg.nse file from this folder.

2. Install the new, appropriate license, which you can find in the attached file. Save the license to a folder on your computer and install it as follows:
Services application -> Utilities -> License -> Install HARDLOCK License

3. Check that the light indicator of the connected USB dongle (blue or white stick) is on all the time. To test it, you can connect the dongle to a different port.

4. Install the current hardlock driver if the light indicator is off.
You can find detailed instructions here:

https://connect.allplan.com/en/faqid/20131028125253.html

5. Select the Services application -> Utilities -> License -> License settings -> Licenses.
Check if "Allplan FT" is displayed in the white window on the left. If this is so, Allplan has accepted the dongle.

If this is not so, send the logmes.nse file, info.001 file and the new servcfg.nse file (license folder) to support.de@allplan.com


Download PDF  FAQ_EN_First_steps_to_solving_hardlock_license_probl...
Version:  Allplan 2020 / Allplan 2019 / Allplan 2018 / Allplan 2017 / Allplan 2016  | Last modified: 23.09.2019
Not voted yet. Be the first to vote this FAQ as helpful!

Question:

I purchased a new license and received a Product Key for Allplan. However, I use earlier Allplan versions with NemSLock server in my office. How can I install Allplan 2015 or an earlier version despite the new license? How can I activate the license on NemSLock server?


Answer:

Allplan 2016 introduced a new protection system. Since then licensing has been based on CodeMeter by Wibu Systems AG. You can no longer use NemSLock server with Allplan. For running Allplan, you get a Product Key by email. Using this key, you can activate your license online.

This new license is not downward compatible. Consequently, you cannot use it for earlier Allplan versions.

If you want to install Allplan 2015 or an earlier version, use a trial license to install the version you need.

Downloading Allplan:
Make sure the Allplan version you install is always up-to-date. In other words, it should include the latest hotfixes and service releases.
You can download the current Allplan version from Allplan Connect or the FTP server.
Downloading from Allplan Connect:
https://connect.allplan.com/de/support/downloads.html

FTP server:
Copy this link and paste it into the address bar of Windows Explorer. Then press ENTER.
ftp://nemhotline:ha37jvg8f@ftp.nemetschek.de
This opens the folder on our FTP server.

Go to /download/Allplan/2015/CD (choose the path in accordance with the version you need) and select the appropriate file. Then click Edit -> Copy (Ctrl+C).
Switch to a folder on your computer and select Edit -> Paste (Ctrl+V).
Extract the ZIP file. Right-click the EXE file and select "Run as administrator".
Deactivate the virus scanner during installation.


1. Install Allplan with a trial license
Install Allplan. In the 'Select License Information' dialog box, choose 'Trial license for temporary use' and select the license for 'Architecture' or 'Engineering'.

Important: If you work with Workgroup Manager, select 'Different trial license' -> 'Next'. Open the Workgroup folder for your country and select the appropriate license. Then follow the instructions and install Allplan. Make sure you enter the paths correctly.


2. Use NemSLock server to request a registered license for the new seat

If you have not used a license server until now, install the license server using the trial license for NemSLock Server.

Installing NemSLock Server

  • Start the Setup program for NemSLock Server. You can find the latest Setup program on our FTP server:

ftp://nemhotline:ha37jvg8f@ftp.nemetschek.de/download/Allplan/Lizenzserver/2014/allplan2014-nemslock-lizenz.zip

  • The trial license is also on the FTP server:

ftp://nemhotline:ha37jvg8f@ftp.nemetschek.de/download/Allplan/Lizenzserver/Allplan 2015 Nemslock Server Trial.nslsrv

  • Select the trial license file for NemSLock Server. This license is valid for 30 days, but it includes only seat. The full number of seats purchased will be available to you as soon as you have installed the registered licenses (see below).
  • Select the full installation.
  • If the service does not start automatically after Setup, select Control Panel -> Administrative Tools -> Services and start the Nemslock Server 2006 service.



Registering licenses

  • Open NemSLock 2006 Server Consoleby clicking the corresponding icon on the desktop or by selecting Start -> All Programs -> NemSLock 2006 Server -> NemSLock 2006 Server Console.
  • Switch to Moduleson the left.
  • Select one of your seats.
  • Click the Registration request (register.txt)button.
  • Click Edit.
  • Fill out all fields marked with an asterisk (*). Make sure you enter your email address correctly, because the registered license file will be sent to this address (and not to the address of the person who sent the registration request!). Click OKto confirm.
  • Click Create registration request. Windows Explorer opens and shows the register.txt file.
    If you have closed Windows Explorer, you can find the file in the program folder of NemSLock Server. If you installed the program to the path proposed, the path is
    C:\Program Files (x86)\Nemetschek\NemSLock Server 2006\Programs\License.
  • Use an editor to open the new register.txt file.

You can find the entry for your seat in line @23@seat:. Change it and enter your new seat number instead. For example, if you purchased seat 08, change the entry to @23@seat: 08. Save the file.

  • You can now use all the options provided by Windows Explorer to copy the registration file to a computer with Internet connection. You can do this on the network or you can use a USB stick. You can then email the file to us.
  • Send the email with the registration request to register@nemetschek.de.
  • You will promptly receive your registered license for the new seat.



Installing licenses
Exit Allplan on all workstations.

  • Open NemSLock 2006 Server Console.
  • Click Stop serveron the left.
  • Switch to Moduleson the left.
  • Click Browse and select the registered license file.
  • Click Install license file.
  • After this, you can start the server again by clicking Start server.



Note:

If you purchased several new licenses, you have to generate and send a separate registration request for each seat. Just repeat the steps described above. You will then receive a registered license file for each seat. You must install each file.

Download PDF  FAQ_EN_Installing_an_earlier_version_with_NemSLock_s...
Version:  Allplan 2015 / Allplan 2014 / Allplan 2013  | Last modified: 30.11.2017 17:22
Not voted yet. Be the first to vote this FAQ as helpful!

Question:

How to install and run NemSLock Server?



Answer:

Before installing, check whether the package you received includes the following items:

  • Temporary licenses for NemSLock Server, e.g. 1234567a_001_psd.nslsrv
  • Temporary licenses for clients, e.g. 1234567a_001_psd_client.nslock



How to install NemSLock Server

  • Start the Setup program for NemSLock Server. You can find the latest Setup program on our FTP server:

ftp://nemhotline:ha37jvg8f@ftp.nemetschek.de/download/Allplan/Lizenzserver/2014/allplan2014-nemslock-lizenz.zip

  • Select one of the temporary license files for NemSLock Server. These licenses are valid for 30 days. However, each license includes only one seat of each configuration purchased. The full number of seats purchased will be available to you as soon as you have installed the registered licenses (see below). If you purchased a configuration for one seat only, you will, of course, receive only one temporary license.
  • When you opt for the “Custom” setup type, you can choose between the following program features:
    Console
    You can use this program to administer NemSLock Server. You can also install the console on more workstations so that you can administer the server from a number of different locations. However, you can only connect one console to the server at any one time.
    Server
    The actual license server.
    Logviewer
    This tool analyzes the log files of NemSLock Server.

By default, Setup installs all these features.
If you have several temporary licenses for NemSLock Server, use the server console to install the remaining licenses after the installation. The procedure is described in the section "How to install licenses".


How to register licenses

  • Open NemSLock 2006 Server Console by clicking the corresponding icon on the desktop or by selecting Start -> All Programs -> NemSLock 2006 Server -> NemSLock 2006 Server Console.
  • Click "Modules" on the left.
  • Select the seat you want to register. If your license includes configurations for several seats, you must send a separate registration request for each seat. You will then receive a registered license file for each seat. You must install each file.
  • Click the "Registration request (register.txt)" button.
  • Click "Edit".
  • You must fill out all fields marked with an asterisk (*). Make sure you enter your email address correctly, because the registered license file will be sent to this address (and not to the address of the person who sent the registration request!). Click OK to confirm.
  • Click "Create registration request". Windows Explorer opens and shows the register.txt file. If this window is closed, you can find this file in the program folder of NemSLock Server. If you installed the program to the path proposed, the path is:
    C:\Program Files (x86)\Nemetschek\NemSLock Server 2006\Programs\License
  • Now you can use all the options provided by Windows Explorer to copy the registration file to a computer with Internet access on the network. Alternatively, you can also use an USB stick. You can then email this file to us.
  • Send the email with the registration request to register@nemetschek.de



How to install licenses

  • Open NemSLock 2006 Server Console.
  • Click "Stop server" on the left.
  • Click "Modules" on the left.
  • Click "Browse" to navigate to the registered license file.
  • Click "Install license file".
  • After this, you can start the server again by clicking "Start server".



How to set up users (optional)

  • predefined user ALLis created automatically. If there is no other user, each user is given the privileges of the user ALL. By default, this user can use all licenses but cannot check out any licenses. By double-clicking the user, you can change the user's privileges.
  • predefined user ALLallows all users to use licenses. In order to do this, the users must be able to access the server. You do not need to create individual user profiles until you want to assign specific rights to individual users or limit access to selected users. predefined user ALL. If you want to work only with individual users, you should deactivate the predefined user ALL by revoking the user's right to use licenses.
  • predefined user ALL has administrator privileges unless another user is created and appointed as the administrator. As soon as you have appointed an administrator, ALL no longer has administrator privileges.
  • You can enter users in the “Users.mcf” file. predefined user ALL has administrator privileges again. In addition, each user can once again administer the license server using the console.
  • The administrator user is not a special user. If there are several administrator users, only one administrator user can start the console for this license server at any one time.
  • If you are setting up users without giving administrator privileges to anyone, the program will ask you whether you want to appoint yourself as the administrator.


You can also specify a domain (user authentication for Windows server). However, this is not mandatory. If you do not specify a domain, the program uses the Windows user name for each user.

The program writes the user accounts and the associated access rights as ASCII text to the users.mcf file.

You can find this file in the \Programs folder of the NemSLock Server installation. You cannot rename, delete or move this file. If the program can no longer connect to this file, you must exit NemSLock Server, restart it and enter all users again from scratch. predefined user ALLis retained.

Note:
Experienced administrators can use the PowerShell script NemGenUsers.ps1. This file is in the \Programs folder of the NemSLock Server installation or you can find it as an FAQ in Allplan Connect:

connect.allplan.com/en/faqid/20120907161911.html



How to install and configure clients

  • Use one of the nslock license files you received to install the clients. Do not use the trial license or the license server license. It is irrelevant which of the client licenses you use, as the actual license will come from the license server later.
  • You do not need to register the clients.
  • When switching from Hardlock to NemSLock (server), you need to update the client using a nslock license file.


After having installed the client, you need to switch to the license server:

  • Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager
  • If the license server window is not visible, select "Configure NemSLock Server" at the bottom. Lock this window. All you need to do is click the drawing pin icon.
  • Enter the computer name or IP address of the license server in the empty box. Then click the "Update” icon to the right.
  • Now the user can select one of the seats provided.
  • After having successfully connected to the license server, clear the check boxes for the trial licenses in the area at the top.
  • Click "Close" to complete the configuration. Now you can start Allplan.



Notes:

  • If a user selects several configurations for a seat and starts Allplan, the license server will provide the required licenses; in other words, starting Allplan once might require two licenses. Consequently, fewer licenses are available to other users.
  • 2014-1 and later: If the latest version of License Manager is installed (file version 1. 0. 26. 153 or later, see License Manager- Options- System), you can also select several licenses. If one of the selected licenses is currently being used by someone else, the program will automatically select the next available license.
  • Clients communicate with the server by TCP/IP via port 10977. So you need to configure the firewall accordingly.
  • The license server and the licenses are downward compatible; they can be used in conjunction with older Allplan versions.
Download PDF  FAQ_EN_Installing_and_configuring_NemSLock_Server.pd...
Version:  Allplan 2015 / Allplan 2014 / Allplan 2013 / Allplan 2012 / Allplan 2011 / Allplan 2009  | Last modified: 11.07.2016
Not voted yet. Be the first to vote this FAQ as helpful!

Question:

I have received a license for my dongle. How can I install this license?



Solution:

1. License on hard disk (or network drive)
Copy the license files to any folder, for example, C:\License, and select this folder when you install the license.

a. During setup
While installing Allplan, select the 'License file from any folder' option and choose the folder with the license files.

b. Installing a license later
To install the license, select
Services application -> Utilities -> License -> Install HARDLOCK License
A dialog box appears. Select the folder with the license files.

2. License by email
If you have received the license by email, save the attachment to any folder, for example, C:\License, and proceed as described in step 1.
If the licenses are compressed (*.zip), extract them first using an appropriate program, such as Winzip (www.winzip.de).

3. License on storage medium (CD or USB stick)
You can also copy the license files to a storage medium (USB stick, for example) or write them to a CD and then proceed as described in step 1b.



Notes:

  • If you have received a license for a license server, read the instructions in the documents for the license server. If any questions arise, contact technical support.
  • Keep the license in a safe place as you may need it for future installations or if there are problems.
  • Make sure you install the license that is appropriate to the dongle you use, as each license matches only a single dongle. time.
  • Setup needs to access the license file(s) during the entire installation process. It is therefore not possible to read the license file(s) from a CD and then remove this CD during installation. You are advised to copy the license file(s) to a folder on the hard disk.
Download PDF  FAQ_EN_Installing_license_for_dongle.pdf
Version:  Allplan 2013 / Allplan 2012 / Allplan 2011  | Last modified: 11.12.2015
2 user(s) found this FAQ helpful

Question:

How can I use Allplan to create PDF documents (Portable Document Format) that can be opened and viewed using PDF viewers such as the free Acrobat Reader?



Answer:

You can export PDF files directly from Allplan.
In addition to the design, bitmap areas and text, the direct export tool transfers layers, OLE objects, transparency and gradients.
Of course, you can also use external programs such as Adobe PDF and FreePDF to create PDF files. However, these programs do not provide all the options mentioned above. For example, transparency is not transferred.

Allplan provides the following options for exporting PDF data:

1. using the layout editor:
Create -> Plot Layout -> Export PDF Data

2. using the print preview:
Click the Export PDF Data icon in the toolbar at the top

3. exporting 3D PDF files from the animation window:
You can create a PDF file from the animation window. This file contains the 3D model displayed in the animation window.
This option is not described any further in this FAQ.


General settings:

When exporting PDF data, you specify the file name in a dialog box, where you can also make basic settings for the PDF file:

  • Resolution (in dpi)
  • Document size (paper size (with margin) or printable area (without margin))
  • Entire layout content
  • Archiving format PDF/A 1a
  • Export layers
  • Embed TrueType fonts
  • ...
  • Add to file (first select an existing PDF file in this dialog box and then select this option -> the PDF file is attached as a new page to the existing file)
  • Grayscale (version 2011 and later)
  • Open file with associated application (should be selected. After you have created it, the PDF file automatically opens in this application so that you can check it.)



Note on the page format (new in Allplan 2011):

In Allplan 2011 and later versions, you set up a page in Allplan. The page size should be used as the size for the PDF file.
You need to exactly define the size you require for the page.

To use the page size for exporting the PDF file, select the following options:

  • Select 'Paper size (with margin)'.
  • Clear the 'Entire layout content' check box, if necessary.



Notes on 1. settings in the Plot Layout module:

You can make advanced settings in the "Plot Layouts" dialog box.
The following settings are used for exporting PDF data:

  • Plot elements / options (Selection tab)
  • Paper format and orientation (Output tab); see the above notes on the page format.
  • Resizing: Resizing factor, resize pen thickness and rotation by 90° (Settings tab)
  • Pen and color assignments... (Settings tab)
    -> Line thickness for monochrome output and line colors for color output
    -> Line display in color, black or using shades of gray (can only be changed when you select a color printer beforehand)
    -> Gamma correction
  • No pen optimization/ Use one pen only (number:)
  • Plot profile (Settings tab)




Notes on 2. settings in the print preview:

The PDF file is exported as it is currently displayed on screen.
You can make the settings that are used for the "Print" tool directly in the print preview (Display tab in the Print Preview Options).



Notes:

To export PDF data in color, you need to install a printer driver that supports color and select this driver in the layout before you start exporting the PDF data.
It is advisable to install a printer driver for a large-format color plotter such as an HP DesignJet even if your office is not equipped with a large-format printer/plotter.
[Install as a local printer/ without plug & play, port: FILE, do not share the printer, do not print a test page.]

Download PDF  FAQ_EN_Creating_PDF_files.pdf
11 - 20 (21)
| A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z |
https://campus.allplan.com/ uses cookies  -  More information

Accept