Illuminazione falsata con rendering "Global"

Etiquetas:

Buongiorno a tutti, sono un geometra che si sta perfezionando con Allplan 2013. Il nuovo metodo di calcolo rendering Global illumination è nettamente superiore al Ray tracing, ma sto riscontrando dei problemi di visualizzazione. Con un progetto in particolare, utilizzando il rendering Global mi illumina oltremodo il modello rendendolo completamente bianco, come se i parametri di illuminazione fossero altissimi. In realtà le condizioni di luce sono bassissime (solo il sole come fonte di illuminazione con luminosità 6 su 255......). Anche aumentando le condizioni di luce a parametri "normali" il render risulta illuminato oltremodo come nelle precenti condizioni di bassa luminosità, nè più nè meno...
La cosa ancora più strana, invece, è che escludendo il sole come fonte di luce e lasciando solo quelle dei punti cardinali il modello risulta completamente buio, con qualsiasi parametro di luce...
tutto questo non accade con il classico rendering Ray tracing, il quale risponde alle impostazioni di luce in modo del tutto normale.
D'altra parte questo problema non si verifica su altri progetti realizzati, ma solo su uno in particolare...
In questi giorni, tra l'altro, mi è andato due volte in crash (si è chiuso il programa improvvisamente ed è uscita la maschera di invio dell'errore) e la prima volta mi hanno risposto con l'aggiornamento dei driver della scheda video, ma a quanto pare non è servito perchè il crash si è ripresentato e ancora non mi hanno risposto.
Vi allego le immagini così potete capire il problema...
Ho bisogno del vostro aiuto perchè questo mi rende impossibile lavorare ed è un progetto di una certa importanza...
Versione: Allplan 2013-2
vi ringrazio in anticipo dell'aiuto e della disponibilità.
Attendo al più presto vostri commenti, spero risolutivi...
Buon lavoro

Adjuntos (3)

img
Ray tracing - illuminazione normale.jpg
Type: image/jpeg
Descargado 479 veces
Size: 648,61 KiB
img
Global illumination - illuminazione…
Type: image/jpeg
Descargado 461 veces
Size: 544,54 KiB
img
Global illumination - illuminazione…
Type: image/jpeg
Descargado 448 veces
Size: 565,93 KiB
1 - 10 (10)
  • 1

Senza i dati non è così semplice verificare il modello eventuali problemi nel modello / settaggi.
Tuttavia, prova così:

1) Avvia l'animazione del modello e salvala in formato "virtuale" FIL (con relativi aspetti, luci, ecc.)
2) Crea un progetto nuovo, avvia l'animazione di un quadro vuoto e carica il modello film salvato precedentemente. In fase di caricamento del modello FIL puoi decidere cosa caricare: in questo caso carica tutto tranne le luci (in questo modo siamo sicuri che non ci sia qualche parametro sole/luci che infastidisca il calcolo).
3) Imposta la proiezione che desideri e prova ad avviare il rendering GI

Se così funziona, probabilmente ci sono elementi "difettosi" da ricercare nei settaggi delle luci (file animatio.cfg salvato nella cartella del progetto) / nel modello "reale" . A tal proposito potresti ad esempio utilizzare la nuova funzione Evidenzia modelli critici.

Se anche così non funziona, verifica se ci sono driver della tua scheda grafica aggiornata. A tal proposito puoi eventualmente utilizzare il systemtest 2013 .

Per acpire se è un problema di driver, la cosa migliore sarebbe quella di condividere almeno il modello virtuale (file FIL) con l'assistenza tecnica / postarlo qui in modo tale da provare a lanciare un rendering su un altro PC.

Spero ti sia di aiuto... Ciao Massimo

Freedom means the opportunity to be what we never thought we would be

Adjuntos (2)

img
salva modello film.png
Type: image/png
Descargado 562 veces
Size: 255,81 KiB
img
Carica modello film.png
Type: image/png
Descargado 444 veces
Size: 42,09 KiB

Innanzi tutto vorrei ringraziarti per la disponibilità e la rapidità di risposta...
ho provato a fare come mi hai detto tu: ho salvato il modello film (che tra l'altro non so nemmeno il suo scopo e uso) e l'ho caricato su un file completamente nuovo escludendo le luci ma il risultato come puoi vedere è il medesimo...
Mi puoi spiegare per favore cos'è questo modello film e come posso utilizzare l'altra funzione che mi hai detto, quella della verifica automatica degli errori???
grazie mille
attendo risposta al più presto...

Adjuntos (1)

img
Global illumination - film caricato.jpg
Type: image/jpeg
Descargado 446 veces
Size: 506,06 KiB

Ogni volta che tu avvii l'animazione, Allplan genera un modello "virtuale" corredato da tutte le sue informazioni (aspetti, luci, ecc.). La tecnica del FIL, ad esempio, è utile per trasportare da un progetto all'altro gli aspetti e le luci utilizzate (disattivando la prima opzione modello) oppure per "liberare" della memoria. Come avrai notato, caricando il FIL in un progetto / quadro vuoto, il tempo di apertura dell'animazione è sensibilmente velocizzata poiché il calcolo del modello virtuale è già disponibile. Al contrario, ogni volta che premi F4, Allplan ricalcola sempre il modello da zero.

Per quanto concerne lo strumento di controllo di cui ti ho parlato, guarda questo video dal minuto 0:36:15 in poi.

Per maggiori info, nell'area TRAINING - Documentazione è disponibile il PDF
delle Novità Allplan 2013 dove viene spiegato ancora più in dettaglio (da pagina 49 a 51).

Potrebbe infatti esserci un problema di coordinate eccessive (molto distanti dal punto globale 0,0,0) che potresti risolvere banalmente spostando il modello oppure qualche elemento particolare che “sporca” il calcolo.

Se ancora non ottieni il risultato desiderato, la cosa migliore è quella di fornire almeno il modello virtuale all'assistenza tecnica. Se infatti, su un altro computer non si dovesse manifestare più, ci sarà sicuramente da lavorare sul driver della scheda.

Ciao Massimo

Freedom means the opportunity to be what we never thought we would be

Adjuntos (1)

img
Evidenzia dati modello critici.png
Type: image/png
Descargado 391 veces
Size: 204,66 KiB

ho provato anche a fare queste verifiche e mi segnala solo due punti critici ma nulla di rilevante...
e poi non capisco come questo possa influire sull'illuminazione in fase di rendering...
e poi se fosse un problema di scheda video avrei gli stessi risultati anche con altri progetti, invece non è così...
cos'altro potrebbe essere???
macro difettose potrebbero reagire così???

Come suggerito, se puoi, invia il progetto e relativo file FIL all'assistenza tecnica.

support@allplan.it

In questo modo sarà possibile analizzare in dettaglio i tuoi dati.

P.S.: quando invii la e-mail, per agevolare il lavoro del tecnico che ti seguirà, indica questo link del tuo post, che trovi qui di seguito:

https://connect.allplan.com/it/forum/in-evidenza.html?tx_mmforum_pi1[action]=list_post&tx_mmforum_pi1[tid]=21693

Ciao Massimo

Freedom means the opportunity to be what we never thought we would be

ok, grazie per l'aiuto... Il problema è che mi è appena scaduto il contratto annuale di assistenza tecnica.....
sto provando e riprovando un sacco di cose ma non riesco proprio a sistemare il problema...
ho provato anche a trasferire alcuni quadri su un file completamente nuovo e poi a costruire su un quadro nuovo 4 pareti a caso con relativi aspetti per vedere il risultato: anche sul file nuovo c'è il problema e anche le nuove pareti subiscono l'errore di illuminazione. è come se tutti i quadri di quel progetto incriminato si portino dietro l'errore, anche trasferendoli in altri progetti...
tra l'altro, l'illuminazione e la luminosità delle texture dipendono dal punto in cui lancio il rendering (mentre le ombre rimangono giustamente orientate sempre nello stesso modo)cosa che non dovrebbe succedere in quanto la sorgente luminosa è fissa.
Pensi ci possa essere dell'altro dietro???
magari un problema di hardware???
spero di essermi spiegato bene...
attendo tue notizie

Il problema sembra legato ai dati di questo progetto. A questo punto, se tutte le prove eseguite fino ad ora non hanno portato ad alcuna soluzione, diventa complicato procedere a tentativi senza poter disporre dei tuoi dati & collegarsi in remoto per verificare lo stato del tuo computer.

Inoltre, per ragion di correttezza nei confronti dei clienti in contratto (che devono avere priorità), non posso darti ulteriore aiuto, quindi, se interessa, allego il modulo di richiesta supporto per i clienti senza S+

Ciao Massimo

Freedom means the opportunity to be what we never thought we would be

Adjuntos (1)

Type: application/pdf
Descargado 576 veces
Size: 22,68 KiB

ok, grazie...
ti allego comunque i render dove puoi vedere la risposta della luminosità a seconda della posizione (notare l'erba in primo piano e poi in lontananza come varia, così ti è più facile capire il problema...
volevo chiederti solo una cosa ancora...
ti allego un altro render dove puoi notare come le texture risultino alterate nella trama, mi spiego meglio... Come puoi vedere il rivestimento dei capannoni è una texture che richiama la lamiera grecata, quindi una superficie con delle creste disposte in senso verticale...
in fase di rendering, però, anzichè farmi vedere la texture correttamente e quindi con tutte le bande verticali, mi risulta questa sorta di profilo ad onda che rende qualsiasi render impresentabile su riprese dalla distanza...
anche le texture di quella copertira grigiastra nel cortile da questo problema, ogni qual volta lavoro con texture a trama verticale o orizzontale ravvicinata...
ovviamente da vicino la texture viene elaborata correttamente...
a cosa è dovuto questo problema???
è allplan che non ce la fa? è un problema di scheda video o di processore???
grazie ancora

Adjuntos (3)

img
GI - posizione 1.jpg
Type: image/jpeg
Descargado 492 veces
Size: 947,23 KiB
img
GI - posizione 2.jpg
Type: image/jpeg
Descargado 481 veces
Size: 625,83 KiB
img
difetti texture.jpg
Type: image/jpeg
Descargado 626 veces
Size: 786,55 KiB

Cita de: Massimo
Il problema sembra legato ai dati di questo progetto. A questo punto, se tutte le prove eseguite fino ad ora non hanno portato ad alcuna soluzione, diventa complicato procedere a tentativi senza poter disporre dei tuoi dati & collegarsi in remoto per verificare lo stato del tuo computer.

Inoltre, per ragion di correttezza nei confronti dei clienti in contratto (che devono avere priorità), non posso darti ulteriore aiuto, quindi, se interessa, allego il modulo di richiesta supporto per i clienti senza S+

Ciao Massimo

Freedom means the opportunity to be what we never thought we would be

Adjuntos (1)

Type: application/pdf
Descargado 689 veces
Size: 22,68 KiB
1 - 10 (10)
  • 1

https://campus.allplan.com/ utiliza cookies  -  Aqui

Acéptalo