[Question] Python Part dissapear after creation with Visual script


Hi all, I am new with Visual Script.

I create a new object via Visual Script, then save it.
When I click Close (in the pallette) or ESC, the object dissapear from the screen.
Create model is ON. After saving appear in the library without picture. Where am I wrong?

Thank you.

Attachments (3)

img
1.png
Type: image/png
Downloaded 20 times
Size: 518,13 KiB
img
2.png
Type: image/png
Downloaded 13 times
Size: 569,67 KiB
img
3.png
Type: image/png
Downloaded 16 times
Size: 297,22 KiB
1 - 8 (8)
  • 1

Hallo Petrov

From the screenshot you provide, it seems that you are using Allplan 2021-0-6 or 2021-0-7. We tested from our side we don't have such an issue.

Could you please provide some information from Allplan trace? Normally, if something goes wrong, it will provide some addtional information about the problem. Allplan trace can be opened from Allplan Services. (see attached screenshot)

Apart from that, could you try following to check, if it helps/works?

  • run the script directly from Allplan library, or
  • reload the project or drawing file after save the PythonPart (vs) object

Attachments (1)

img
AllplanTrace.png
Type: image/png
Downloaded 10 times
Size: 104,73 KiB

Hello Xinling, thank you for your reply.

Please see the attached pictures.
1. I choose the element "Column Two Floors" from the library
2. If I click "Close" nothing happened, if I click ESC, the lines disappear (the handles not)
3. Check Allmenu=>Service

Best regards,
Stefan

Attachments (3)

img
2.png
Type: image/png
Downloaded 8 times
Size: 414,84 KiB
img
3.png
Type: image/png
Downloaded 5 times
Size: 370,98 KiB
img
4.png
Type: image/png
Downloaded 7 times
Size: 433,97 KiB

sorry I didn't explained it correctly...

After you turn on the trace, if you try to create a PythonPart again from Visual Scripting or directly from library in Allplan. Does it show any additional information? Could you provide some screenshot or just paste the information from trace?

Unfortunatly does not provide any addtional information.
I try to create a file - Allplan.out, but this file is not created as well.
If you need some other information?
I attach the pyp file, if It can help.

Attachments (1)

Type: text/xml
Downloaded 4 times
Size: 29,11 KiB

Normally if you choose to show trace and let it write to window, you will get a separate trace window which show some runtime information, after you restart the allplan.

I just tried the script you attached, trace window did show some error (see attached screenshot). We will analyze the problem. Did you get a similar error?

And what kind of error do you have, if you create a PythonPart object via Visual Scripting?

Attachments (1)

img
Error.png
Type: image/png
Downloaded 18 times
Size: 45,75 KiB

Hope this will help you to understand better.

Attachments (1)

img
Trace.png
Type: image/png
Downloaded 26 times
Size: 268,44 KiB

Thanks for providing the screenshot. I've already informed our developer to check this issue. I will reach you back, if there is any solution for solving the problem.

1 - 8 (8)
  • 1

https://campus.allplan.com/ uses cookies  -  More information

Accept