Das Wissen aller Anwender nutzen

Im Allplan Connect Forum tauschen sich Anwender aus, geben wertvolle Tipps oder beraten sich bei ganz konkreten Aufgabenstellungen − auch international.
Und damit wirklich keine Frage unbeantwortet bleibt, unterstützen die Mitarbeiter des Technischen Supports ebenfalls aktiv das Forum.

Es erwarten Sie:

  • Foren-Vielfalt aus CAD Architektur, CAD Ingenieurbau uvm.
  • Tipps von User für User
  • international: Deutsch, Englisch, Italienisch, Französisch und Tschechisch

Melden Sie sich jetzt an und diskutieren Sie mit!

Zur Registrierung

dwg stift-übergabe [Gelöst]


Vielleicht lesen ja hier mehr leute
Will einen plan mit eingeschalteter farbe zeigt stift übergeben. die dwg soll aber die farbe von der stiftdicke übergeben und nicht die farbe als farbe. Gibts da möglichkeiten.? Wenn ich die dwg in acad öffne ist alles schwarz bzw. so wie als Farbe hinterlegt.

1 - 8 (8)
  • 1

Hallo Sascha

nun, eigentlich, wenn in der Bildschirmdarstellung "Farbe zeigt Stift" eingeschaltet ist, dann werden die Farben der Stifte exportiert.
Schwarz sind die meisten Farbeinstellungen der 2D-Layer. Wenn du also in der Bildschirmdarstellung "Farbe zeigt Stift" gerade ausgeschaltet hast, wird alles in nur schwarz exportiert.
Kurz, die Elemente werden in den Farben exportiert, die du am bildschirm siehst.
Ganz anders, wenn du die Formateinstellung der Layer auf "von Layer" eingestellt hast. Dann kann es passieren, dass die Farben zwar exportiert werden, aber in autocad nur in schwarz ankommen.
Entweder du nimmst die einstellung "Von Layer" von der zu exportieren Kinstruktion weg (siehe roter Korrekturstifft oder über Palette "Eigenschaften" oder
stell beim Exportieren im Register "erweiterte Einstellungen" "Aufzulösende Verknüpfung" "von Layer " ein. (siehe Bild)

lg
Undine Ritzmann

Anhänge (1)

img
Aufnahme1.jpg
Typ: image/jpeg
334-mal heruntergeladen
Größe: 99,28 KiB

Nicht ganz. egal,ob ich farbe zeigt stift ein oder aus habe. Spätestens beim Übergeben im Feld exportieren, habe ich ja keine möglichkeit der stiftdicke die farbe zuzuweisen. die umwandlung erfolgt ja nur als farbe =farbe. habe von layer aus hat damit nichts zu tun. es fehlt eine funktion in der ich während eines DDDWWWGGG exportes dies einstellen kann. oder ??

[quote="Sascha Decker"]
Nicht ganz. egal,ob ich farbe zeigt stift ein oder aus habe. Spätestens beim Übergeben im Feld exportieren, habe ich ja keine möglichkeit der stiftdicke die farbe zuzuweisen. die umwandlung erfolgt ja nur als farbe =farbe. habe von layer aus hat damit nichts zu tun. es fehlt eine funktion in der ich während eines DDDWWWGGG exportes dies einstellen kann. oder ??
[/quote]

tut mir leid Sascha, aber was du schreibst stimmt für mich nicht. Habe es gestern auch extra noch einmal ausprobiert und bestätigt bekommen.
In den Optionen kannst du dazu nicht einstellen, aber mit dem OK kannst du über "Verändern" der Konvertierungsdaten nachschauen. Im REgister Farben siehst du die Farben, die du am Bildschirm siehst (so der Stifte) und im Register Stift natürlich nur die Strichstärken.
Dort kannst du ggf. deine Farben korrigieren. Geht natrülich nicht, wenn nur Schwarz ankommt.
Ich habe es auch extra noch einmal mit "Von Layer" ausprobiert und bestätigt gesehen, dass dann nur Schwarz ankommt. Deswegen bekommt man oft aus Autocad nur Schwarz, wenn die nur mir "Farbe von Layer" arbeiten.

lg
Undine Ritzmann

tschuldigung ich glaube wir reden immernoch aneinander vorbei. ich möchte wenn ich mit farbe zeigt stift z.b. 0.35 in magenta als stiftfarbe zeichne diese übergeben(sprich magenta) nicht die tatsächliche farbe die ich diesem magentastift zugeordnet habe.wenn ich einen plan mit vielen farben habe, kann ich in anderen programmen wie auch z.b. glaser nichts anfangen. natürlich kann ich beim export alle farben umstellen und neu zuordnen. das ist aber nicht mein ziel.
bis version 15 hingen die stiftdicken automatisch an der Kopplung. da war es einfach. nun halt nicht mehr.vielleicht schaffe ich am wochenende mal ein paar screnshots. danke für die antworten schon mal bis hierher

[quote="Sascha Decker"]
tschuldigung ich glaube wir reden immernoch aneinander vorbei. ich möchte wenn ich mit farbe zeigt stift z.b. 0.35 in magenta als stiftfarbe zeichne diese übergeben(sprich magenta) nicht die tatsächliche farbe die ich diesem magentastift zugeordnet habe.wenn ich einen plan mit vielen farben habe, kann ich in anderen programmen wie auch z.b. glaser nichts anfangen. natürlich kann ich beim export alle farben umstellen und neu zuordnen. das ist aber nicht mein ziel.
bis version 15 hingen die stiftdicken automatisch an der Kopplung. da war es einfach. nun halt nicht mehr.vielleicht schaffe ich am wochenende mal ein paar screnshots. danke für die antworten schon mal bis hierher
[/quote]

schon mal die Antwort bis zum Wochenende,

ich glaube es richtig verstanden zu haben. Ein Element, gezeichnet mit Stift 2=0.35 wird auf weißen hintergrund an Magenta gekoppelt am Bildschirm gezeigt. Das Element wurde auch in der Formateigenschaft "Linienfarbe" zum Bsp. Schwarz gezeichnet, die ich bei eingeschaltetem "Farbe zeigt Stift" am Bildschirm nicht sehe. So exportiert, wird magenta als Farbe übernommen. Zumindest sieht es in der Konfiguration der Konvertierung so aus.
Und importiert kommt das Element in magenta an.
Aber vielleicht helfen uns Screenshorts wirklich weiter.

lg
Undine Ritzmann

Hallo Sascha,
probiere doch bitte mal folgendes:
In der Bildschirmdarstelung Farbe zeigt Stift einschalten und dann beim exportieren der Daten in den Optionen der ODX Schnittstelle und dort im Register Allgemeine Einstellungenund dort im Bereich Übertragungsart: die Option sichtbare Daten einschalten.

Es grüßt
MT

Hallo Fr. Schmidt,Fr. Ritzmann,Hr. Terfloth, danke für die Mühen und die Antworten. Ich finde die seite bis jetzt wirklich super. Ich glaube mit dem haken sichtbare daten ist es wohl am besten. habe ich bis jetzt auch schon mal probiert.es kommt dann wenigstens der stift als farbe an. der layer wiederum bleibt sxhwarz. Kann ich aber da mit eigenschaftenfilter ändern. Ich teste das ganze mal noch mit festen layer. Denke das ist dann aber auch eheer ein problem von dwg und nicht von allplan. Danke

1 - 8 (8)
  • 1

https://campus.allplan.com/ verwendet Cookies  -  Mehr Informationen

Akzeptieren