PDF size too big [Vyřešeno]


Hi,
I have the problem, that the size of the PDFs I create with Allplan is too big. Every time I try to open them with Photoshop to further edit them my computer crashes.
I create the .pdf-file by “Export PDF Data” within the print preview. Is there a setting I can adjust in Allplan to prevent the PDF of getting that huge without altering the resolution (I really can’t lower the resolution)?
It would be awesome if someone had a solution for my problem.

greeting
Urella

1 - 10 (10)
  • 1

If you have paint in layout try reducing the value of dpi, for example 150

Hey, sorry that I unswer so late.
I'll try, thanks for help!

best regards
Urella

[quote="Urella Fandarou"]
Hi,
I have the problem, that the size of the PDFs I create with Allplan is too big. Every time I try to open them with Photoshop to further edit them my computer crashes.
I create the .pdf-file by “Export PDF Data” within the print preview. Is there a setting I can adjust in Allplan to prevent the PDF of getting that huge without altering the resolution (I really can’t lower the resolution)?
It would be awesome if someone had a solution for my problem.

greeting
Urella

[/quote]

Hello Urella,
in the majority of cases this is because the plan includes extended Fills with color Transition and/or transparencies. By exporting your plan into PDF the Fills are converted into bitmap images, which usually leads to a higher data volume. Too many Smart Symbols could also be the reason. Or maybe you’ve got some circles in your plan that were drawn with a 360° splitting which boosts your data volume exponentially?

Try using the command “File” --> “Save and Compress” before creating the PDF.

To reduce the data volume a PDF printer driver can be used. Keep in mind that the output of transparencies is only possible with the direct PDF export of Allplan. During the creation of PDF files by using the PDF printer driver, bitmap images with Color Transition/transparencies cannot be passed because those programs first create a Postscript file from which the PDF file will be created. But the postscript format doesn’t support transparencies and Color Transitions.

best regards
Undine Ritzmann

Hello

Thank you for answering so fast. It really might have the cause in the transparencies and transitions. I do have a lot of them in my drawings.
I tried “save and compress” before but apparently the circles aren’t the cause either.
Just “printing” the PDF does also not work.
So is there a possibility to create smaller PDFs with many transitions and so on?

regards
Urella

Dear Urella

first look for the answer of hatem the side up. Tihs is also a possibility to reducing the value of PDF-File.

or

Well I don’t know how you’ve drawn your plan but you could divide it into several parts which you can export as PDFs one by one. Then you can import those files into Photoshop and safe them in another format. That way you might reduce the data volume. After the reduction you can put the several parts of your plan back together and proceed working.

It might be worth a shot. It would be great if you’d share your experience here.

best regards
Undine Ritzmann

Thanks for your answers. I had the same idea and it actually works that way.
I created individual drawings for every view, sectional view and so on. The PDFs for all of these drawings weren’t that big anymore. I imported them into Photoshop and saved them as .jpeg. Afterwards the file size was about 2/3 less.
I could merge the several jpeg-files in Photoshop and make a new layout. By reducing to one layer and saving as .jpeg even my plotter could handle the plan and plotted it without any problems. All things considered it’s a complex task because you always have to check the scale and so on so that there goes nothing wrong but at least it’s a solution for my problem.
Thanks
Urella

[quote="Urella Fandarou"]
Thanks for your answers. I had the same idea and it actually works that way.
I created individual drawings for every view, sectional view and so on. The PDFs for all of these drawings weren’t that big anymore. I imported them into Photoshop and saved them as .jpeg. Afterwards the file size was about 2/3 less.
I could merge the several jpeg-files in Photoshop and make a new layout. By reducing to one layer and saving as .jpeg even my plotter could handle the plan and plotted it without any problems. All things considered it’s a complex task because you always have to check the scale and so on so that there goes nothing wrong but at least it’s a solution for my problem.
Thanks
Urella
[/quote]

Dear Urella

You also can create .jpg’s with Allplan. Within the module “Layout Editor” you’ll find the function “Export HPGL-File, Bitmap-File”.

Plans can be exported as high resolution pixel files in established data formats as *.psd for instance.

However, the data volume depends on the size of the plan and the selected resolution. Also keep in mind that the “pen and color assignments” that can be adjusted in the function “Plot Layouts” will be exported, too. If needed, you should alter these settings before that.

Use the function „Save Contents of Viewport as Bitmap…“from the menu „File“ if only parts of the plan need to be exported as high resolution pixel files. Close the Layout Editor for it.

best regards
Undine

Přílohy (3)

img
Aufnahme6.jpg
Type: image/jpeg
Staženo 579
Size: 25,21 KiB
img
Aufnahme7.jpg
Type: image/jpeg
Staženo 545
Size: 19,25 KiB
img
Aufnahme8.jpg
Type: image/jpeg
Staženo 555
Size: 20,33 KiB

Okay, thanks for all the good hints.

all the best
Urella

1 - 10 (10)
  • 1

https://campus.allplan.com/ používá cookies  -  Více informací

Souhlasím