[Pregunta] PythonParts debug problem [Guardado]


Hi there,

I have got a problem with connecting Visual Studio with Allplan (debug). I do everything as it is said on
http://pythonparts.allplan.com/2016-1/gettingstarted.html, start debug on Allplan, and Visual Studio doesn't work properly. Error message says: "Error while displaying dialog window of selection port for that connection type. Not implemented".

My thought is sth is wrong with ptvsd?

Adjuntos (1)

img
1.png
Type: image/png
Descargado 84 veces
Size: 192,84 KiB

Show solution Hide solution

Hi,

The problem is the Visual Studio version that you are using. It has to be 2015 Visual Studio.

I had the same problem here.

Diogo

1 - 10 (14)

Hi,

The problem is the Visual Studio version that you are using. It has to be 2015 Visual Studio.

I had the same problem here.

Diogo

Thanks Diogo, I'll check it later then and tell you if it helped.
Wow, 2 answers to my questions in 10 minutes that forum is starting to be really helpful!

Be careful the link you indicate is no longer the right one =>

http://pythonparts.allplan.com/

(no version of allplan in the address)

Christophe

Ok, I'll remember.

It worked. So the problem was only with VS version. Thanks a lot!

Hello, I am having almost the same issue but using Allplan 2019, ptvsd 3.2.1 and python 3.6.5.
You can check my post here https://campus.allplan.com/en/forum/topics/topic/topics/pythonparts/allplan-2019-pythonparts-debugging-using-ptvsd-error.html with images.
The issue is that i tried both VS2015 and VS2017 but still could not make it work.
Can you help me solve the debug issue or did you try with Allplan 2019?

I have got it work with VisualStudio 2017 (V 15.7) inlcude PythonTools and ptvsd 3.2.1.
I tried it before with ptvsd 4.2.4 and ptvsd 4.1.1a1 (which is recommended from Mircosoft for VS 2017 15.7) and it didn't work !

So it's strictly necessary to use ptvsd 3.2.1 (Aug. 2017) which can downloaded here

Thank you Nemo for your helpful reply.
Can you please say what python environment version are you using?
I am using almost the same configuration (VS2017, ptsvd 3.2.1, Allplan 2019, python 3.6.5) but either the port is not opening or the VisualStudio 2017 V15.9 cant connect to it.
Can you post an image from Allplan Trace to see what it shows when it connects etc ?

...here some screenshots.

Adjuntos (2)

img
attached.png
Type: image/png
Descargado 25 veces
Size: 114,04 KiB
img
break_point.png
Type: image/png
Descargado 30 veces
Size: 196,53 KiB

Hi Guys,

I have the same Problem with VS2017, ptsvd 3.2.1 or 4.2.10, Allplan 2019-1, python 3.6.5.

When I click the StartPythonDebug, Allplan show the Windows, I click OK an then Allplan crashes.

Of Course I can't find the Process in Python...

Some ideas?

Adjuntos (1)

img
Immagine.jpg
Type: image/jpeg
Descargado 1 veces
Size: 66,35 KiB
1 - 10 (14)

https://campus.allplan.com/ utiliza cookies  -  Aqui

Acéptalo