RICERCA AREE CHIUSE [Risolto]

Tags:

Buongiorno a tutti,
ho riscontrato che dalla versione 2014 la ricerca delle aree chiuse avviene con notevole difficoltà; la medesima area, se non individuata nella sua interezza, viene invece individuata suddividendola in tre.....e non parlo di aree complesse.
I parametri di ricerca sono ok...... e lo stesso problema avviene anche su computer del mio collega....desumo quindi che non sia un problema di PC ne di postazione.
Qualche altro parametro? nessuno ha difficoltà nella ricerca automatica?

1 - 8 (8)
  • 1

Ciao, togli la ricerca delle isole!
Sai ormai nel 2014 le isole sono tutte conosciute non c'è bisogno di cercarne altre!! ;)

http://www.app-easy.it | APP-Easy Architecture for Allplan

Quale versione di Allplan si usa?
2014-1-1 opure 2014-1-2 ??

Ti prego provare l'ultimo versione 2014-1-3 .

era una modifica su questa funzione, vedere anche le " release notes " (solo in inglese)

ciao
Jörg velletti
monaco ..

Jörg (Velletti), Allplan Webentwicklung

Man kann mich Siezen oder Duzen. Wie derjenige mag. Und bitte beachten: Supportfragen zu Allplan bitte nur über das Forum stellen und bitte mir nicht als "Persönliche / Private" Nachricht senden. Die kann ich nämlich nicht weiterleiten.

versione utilizzata 2014.1.3
Il problema si risolve, quasi completamente, togliendo la spunta in "visualizza a video" --> "foglio macro A" + "foglio macro B" + "foglio macro C" ......non chiedetemi il perché, è una questione di tentativi!
Premetto che parte del quadro è una importazione di file DWG.

Grazie per le risposte.

forse di dati hanno grande coordinate (importazione di file DWG)?
leggere questo :

Import : Coordinate elevate - 4 possibilità

Coordinate elevate

Jörg

Jörg (Velletti), Allplan Webentwicklung

Man kann mich Siezen oder Duzen. Wie derjenige mag. Und bitte beachten: Supportfragen zu Allplan bitte nur über das Forum stellen und bitte mir nicht als "Persönliche / Private" Nachricht senden. Die kann ich nämlich nicht weiterleiten.

coordinate ok, sia nel DWG che nel quadro allplan.
Se devo creare un riempimento, anche poligono semplice, ma in presenza di polilinea importata da dwg perfettamente allineata, l'area non viene individuata. vedi esempio nell'immagine.
Non tutte le polilinee ma solo alcune.....mistero!

grazie

Allegati (2)

Type: application/octet-stream
260 scaricato
Size: 384,22 KiB
img
riempimento.JPG
Type: image/jpeg
308 scaricato
Size: 24,67 KiB

Utilizzando diversi zoom, è possibile verificare che il DWG originale contiene alcune imprecisioni "infinitesimali". Vedi immagine allegata.

A questo punto, si dovrebbero cercare una ad una. Allplan mette a disposizione alcuni strumenti utili come ad esempio:

Ricerca aree inefficace, cosa fare?
Cancella duplicati
Fondi linee sovrapposte
ecc.

Nel caso specifico, presumo che nel tuo file DWG possano esserci diverse tipologie di errore. Osservando i blocchi dei cerchi e le polilinee, sembra quasi che il disegno sia stato effettuato senza abilitare le opzioni di SNAP punto.

Fatta questa premessa, se lo ritieni utile, ti suggerisco un piccolo "trucco" per far si che gli errori geometrici infinitesimali vengano "normalizzati" in uno step unico.

1) Applica un fattore di scala elevato a tutto il documento (ad esempio 100 sia per la X che per la Y) rispetto al punto globale 0,0,0 (oppure a un punto noto fisso)

2) Crea i riempimenti

3) Applica nuovamente un fattore di scala 0,001 a tutto il disegno rispetto allo stesso punto definito in precedenza.

Ecco come, guardami

Freedom means the opportunity to be what we never thought we would be

Allegati (1)

img
polilinea_in_basso_a_sinistra.png
Type: image/png
287 scaricato
Size: 32,67 KiB

grazie mille,
ho verificato ed in effetti il problema deriva dal file autocad ricevuto....e non da allplan

1 - 8 (8)
  • 1

https://campus.allplan.com/ utilizza cookies  -  Maggiori informazioni

Accetta