Attribute werden im Attributauswahldialog durch verschieben in eine Attributuntergruppe zerstört.


Das geBIMe treibt mich hier schier in die Verzweiflung …

Ich mir eine Elementbibliothek mit eigenen Attributen erstellt. In der Attributauswahl unter Benutzer habe ich mir eine Untergruppe angelegt und dort viele Attribute angelegt. Einige mit ComboBox Eingabemaske mit Vorauswahlen. Nun habe ich gemerkt ich brauche weitere Strukturierung, also eine weitere Untergruppe angelegt und meine Attribute alle dareingeschoben. Soweit so gut. Nur gehen dabei in allen Attributen alle Comboboxvoranwahlen verloren, alle weg einfach so. Die Objekte haben die Attribute noch, aber es steht nur noch die Zahl im Attribut welche den ComboBoxeintrag referenziert.

Is it a Bug oder ein Feature. Ich würde gern wissen ob dies gewollt ist und wenn ja wo steht, das beim verschieben von Attributen die Attribute praktisch zerstört, also nutzlos werden oder ist das ein Bug ?

Das ist beliebig reproduzierbar? Screen anbei. Das Fenster Attribut modifizieren is leer oder hat nur eine 11, da standen vorher duzende Zeilen Text mit den Elmenttypnamen ... Hass, Lust auf Wochenende, dabei ist erst Montag ...

Weiss jemand wo die Texte irgendwo in einer Datei stehen, dann kann ich die über die Sicherung einspielen und brauch sie nur kopieren. Ich hatte über 50 Elementtypen und verschiedense Attribute ...

Gruss bernd

Allplan 2017-1

BIM, BAM, BOOM
BIM-Modelle Tragwerksplaner --> http://www.bimstatik.ch/
My Allplan PythonParts --> https://github.com/BIMStatik/AllplanPythonParts
LinkedIN --> https://ch.linkedin.com/in/bernd-hahnebach-269b855a

Anhänge (1)

img
screen.png
Typ: image/png
254-mal heruntergeladen
Größe: 68,68 KiB
1 - 10 (13)

haben sich die attributnummern auch geändert?

ich weiß nicht mehr auswendig, wo was gespeichert ist...

die auswahl müsste eigentlich im ordner attr im projekt od. büro unter der attributnummer gespeichert sein.

die attributdefinition selbst ist auch gespeichert... in einer xml-formatierten datei. wo kann ich hier gerade nicht nachschauen.

Danke Markus für die Anwort. Du meinst die lfnr im Attributmanager.exe. Mhh kann ich grad nicht sage, ich kenn die Nummern von vorher nicht. Hab eben mit der extensiven Attributierung erst angefangen ... Auf jedenfall fehlen die Einträge.

Ich hab mehr geforscht ... Die lfnr wird duch das hin und herschieben nicht geändert, aber was interessant ist, wenn ich ein neues Attribtut anlege mit ComboBox und Einträge hinzufüge, dann erscheint das im Attributmanager.exe als Datatype Enumeration mit Controltype Enumeration und DefaultValue den Zuordnungen von int-Werten zugeorndet zu den eingegeben Strings. Wenn ich nun das Attribut in eine andere Attribugruppe schiebe dann ist im Attributmanager.exe der Datatype IntegerValue der Controltyte ComboBox und der DefaultValue leer. Perfekt reproduzierbar. Die lfnr bleibt erhalten. Das kann doch nicht sein !

Ich hab ne Sicherung des Projektes, also bin sehr an einer Lösung interessiert. Ich kann aber die Sicherung nicht einfach überschreiben. Ich hab auf anderen Teilbildern viel Geometrie geändert, und die BWS hab ich vollkommen umbebaut. Aber bei der Geometrie ist mir die Attributtierung egal. Bei den betreffenden TBs mit den Attributen hab ich nichts dran geändert, auch die Nr sind noch gleich. Das blöde, der Assistent, mit dem ich alles erstellt habe ist auch in dem Projekt und die Attributierung steht auf Projekt. Heisst ich bin vollkommen blockiert ... Naja mal sehn ...

BIM, BAM, BOOM
BIM-Modelle Tragwerksplaner --> http://www.bimstatik.ch/
My Allplan PythonParts --> https://github.com/BIMStatik/AllplanPythonParts
LinkedIN --> https://ch.linkedin.com/in/bernd-hahnebach-269b855a

Eigentlch müsste ich doch die alte Attributdefinition wieder herstellen und alles wäre wieder io. Falls nicht dann eben die betreffenden Teilbilder auch zurückspielen, und dann sollte ich es wieder haben. Dann wäre zwar die neue Struktur mit den neuen Attributgruppen im Eimer, aber das wäe mir erst mal egal. Dass kann ich dann angehen, mit der neuen Struktur hab ich noch keine Daten. Ich denke mal laut, damit ich morgen auch noch weiss was ich den vorhabe ...

gruss bernd

BIM, BAM, BOOM
BIM-Modelle Tragwerksplaner --> http://www.bimstatik.ch/
My Allplan PythonParts --> https://github.com/BIMStatik/AllplanPythonParts
LinkedIN --> https://ch.linkedin.com/in/bernd-hahnebach-269b855a

Hallo Bernd,

Das es Probleme mit den Enum-Attributen gibt, ist bei Nemetschek bekannt. Scheinbar dieser Fehler nicht.
Bei Deinem Problem ist leider eine Projekt-Sicherung nicht hilfreich, da die Attribut-Ressourcen Büro-Weit gelten! Das was da auf "Projekt" steht, sind die "Attribut-Vorschläge"! Das Einspielen der Projektsicherung bringt also nichts, und ist auch nicht notwendig!
Aber es gibt eine andere Lösung:
1. Die Datei AttributeDefinitionCollectionLocal_de.xml im \Std-Verzeichnis beinhaltet die Attribut-Definitionen. Diese Datei müsstest Du aus der Sicherung oder von der Volumenschattenkopie wiederherstellen, auf den Stand vor Deinen Änderungen.
2. Die Datei attrib_UD.000 im \Std-Verzeichnis enthält die Benutzer-Gruppen. Die kannst Du also behalten.
3.Die wiederhergestellte AttributeDefinitionCollectionLocal_de.xml mit Notepad++ (o.ä. Texteditor) öffnen, und dort bei den gewünschten Attributen den Wert des Tags <ParentUserDirCode> auf den neuen Wert (wahrscheinlich "2") ändern. Den "neuen" Wert bekommst Du heraus, indem Du testweise ein neues Attribut in Deiner neuen Gruppe erstellst. In der XML hat das danach den entspr. Wert bei <ParentUserDirCode>, den Du dann einfach in die anderen Attribute reinkopierst.

Dabei sollte Allplan auf keiner Station aktiv sein.
Vorsichtshalber vorher 'ne Sicherungskopie von der XML machen.

Hintergrund:
Die schon vergebenen Attribute an den Elementen enthalten nur die Attribut-Nummer und den Wert ,
in diesem Fall den Index der Enumeration. Wenn sich jetzt wie bei Dir der Typ des Attributes von Enumeration auf String(-Combobox) ändert, verliert er die Zuordnung der Enum-Indices zu den eigentlichen Strings, d.h. es steht da nur noch "11" statt "BSt500".

In jedem Fall diesen Fehler an die Hotline weiterleiten. Das muss gefixt werden...

Grüße

Jörg

Anhänge (1)

img
parentuserdircode.png
Typ: image/png
193-mal heruntergeladen
Größe: 88,10 KiB

Hallo Jörg,

Vielen Dank Jörg schonmal vorab für die ausführliche Erläuterung. Das hört sich sehr gut an, hab leider selber kein Zugriff auf die Serversicherung ... Ich schau mal, alle Arbeitstationen aus hört sich nach sehr früh oder sehr spät an, das sind über 10 ...

Zitiert von: Nemo
Hintergrund:
Die schon vergebenen Attribute an den Elementen enthalten nur die Attribut-Nummer und den Wert ,
in diesem Fall den Index der Enumeration. Wenn sich jetzt wie bei Dir der Typ des Attributes von Enumeration auf String(-Combobox) ändert, verliert er die Zuordnung der Enum-Indices zu den eigentlichen Strings, d.h. es steht da nur noch "11" statt "BSt500".
Genau das hab ich auch vermutet, als ich die Zahlen gesehen habe, weshalb ich gedacht habe ich brauch nur die Attributdefinition ins Projekt zurückspielen, das die natürlich im std liegt ...

gruss bernd und einen schönen Abend, vieleicht BOOMT das BIM ja doch noch ...

BIM, BAM, BOOM
BIM-Modelle Tragwerksplaner --> http://www.bimstatik.ch/
My Allplan PythonParts --> https://github.com/BIMStatik/AllplanPythonParts
LinkedIN --> https://ch.linkedin.com/in/bernd-hahnebach-269b855a

Hallo Jörg

Zitiert von: Nemo

1. Die Datei AttributeDefinitionCollectionLocal_de.xml im \Std-Verzeichnis beinhaltet die Attribut-Definitionen
2. Die Datei attrib_UD.000 im \Std-Verzeichnis enthält die Benutzer-Gruppen.

Allmenue --> Der Pfad hinter Bürostandard ist der \Std von dem du sprichst

In dem Pfad ist eine datei attrib_UD.000, leider im binary format. Die wurde letztmalig am 24.5. über Mittag geschrieben, passt perfekt mit meiner Gruppenänderung zusammen.

In dem Pfad ist keine Datei AttributeDefinitionCollectionLocal_de.xml ... Ich hab die Attribute am 18.5. erstellt ...

gruss bernd

BIM, BAM, BOOM
BIM-Modelle Tragwerksplaner --> http://www.bimstatik.ch/
My Allplan PythonParts --> https://github.com/BIMStatik/AllplanPythonParts
LinkedIN --> https://ch.linkedin.com/in/bernd-hahnebach-269b855a

Anhänge (1)

img
screen.png
Typ: image/png
201-mal heruntergeladen
Größe: 225,36 KiB

Hallo Bernd,

es geht auch im "laufenden Betrieb". Dann sollte in der Zeit aber keiner neue Attribute anlegen oder welche ändern!
Und: Allplan ist.sehr empfindlich bei Fehlern in der XML. Das kann soweit führen, dass es nicht mehr startet. Also in jedem Fall vorher ein Backup dieser Datei machen...

Gruß
Jörg

Ahh gut das macht sicher keiner, das organisier ich. Das dürfen bei workgroup eh nur admins. Ach und die Datei hab ich auch im Xml ordner ... gruss bernd

BIM, BAM, BOOM
BIM-Modelle Tragwerksplaner --> http://www.bimstatik.ch/
My Allplan PythonParts --> https://github.com/BIMStatik/AllplanPythonParts
LinkedIN --> https://ch.linkedin.com/in/bernd-hahnebach-269b855a

Die besagte XML liegt in /Std/xml

1 - 10 (13)

Verwendung von Cookies:
Um die Webseite optimal gestalten und fortlaufend verbessern zu können, verwendet Allplan Cookies.
Durch die weitere Nutzung der Webseite erklären Sie sich mit der Verwendung von Cookies einverstanden.  -  Mehr Informationen

Schließen