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			Questions:

Why can’t I see anything in a project or why are elements missing from drawing files?
Why are layers not visible?
Why is it not possible to select a privilege set in layer selection?



Answer:

Probably, you have not yet been assigned any privilege sets or the layers are frozen in the privilege set in question. First, check whether you can select another privilege set.


1. Selecting another privilege set

To do this, select the project in question and open the layer settings(Format -> Select, Set Layers). Go to the “Privilege set in list box” area at the top on the right and check whether you can select another privilege set (for example, ALLPLAN).
By default, all layers have full access rights in the predefined ALLPLAN privilege set.

If there is no privilege set with full access rights, you should assign the privilege sets correctly.
This can only be done by a user with administrator privilegesor, in the case of a project-specific layer structure, by the project owner.

Thus, log on as a user with administrator privileges and do the following:


2. Assigning a privilege set

Select the project with the frozen layers.

Open the layer settings(Format -> Select, Set Layers). Switch to the "Privilege Set" tab and click Define, modify privilege set.

Select the relevant user and assign the privilege set using the arrows.

Click OKto confirm.


3. Adjusting layers’ access rights in the privilege set

Finally, check the access rights of the layers in the privilege set assigned.
Go to the "Privilege set in list box" area at the top on the right and select the relevant privilege set (for example, ALLPLAN).

Check the area on the left to see whether there are frozen layers (gray or white). To change this, select these layers or simply select all layers using CTRL+A. Then click the Full access right (modifiable)icon in the “Change rights” area.
Click OKto confirm.

The next time you open this project, you can select this privilege set in the layer settings. You can then see all layers and set them to modifiable.

Do the same with print sets.


Alternative:

Since version 2006, the administrator has been able to select Show all users all print sets and privilege setsin the “Administrator options” group on the “Privilege Set” tab (“Design group” in version 2006). Thus, you do not need to assign new users to privilege sets. This option applies to all projects.

However, as soon as a user has been given a privilege set or print set, this option no longer applies to this user.



Note:

As a project can have its own layer structure, it is essential that you check the privilege set in the correct project.
To find out whether a project has its own layer structure, click
File -> New Project, Open Project-> right-click the relevant project -> Properties. Check whether the path settings for Layerstructuresare set to Officeor Project.
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			Question:

What might cause Allplan not to function correctly in a Microsoft remote desktop environment?
And what can I do to solve these problems?



Answer:

Running graphic-intensive software in a Microsoft remote desktop environment might be restricted because GPU rendering is turned off for Microsoft remote desktop by default. You can solve problems by configuring the Windows local group policy on the host so that GPU rendering is turned on during a remote desktop session. 

Important notes: 
	It is the IT service provider or office administrator who is responsible for configuring the Windows local group policy. This is not part of the support services provided by Allplan’s technical support.
	In this context, Allplan’s technical support does not assume any responsibility for possible problems you might have with your computer.



To configure the local group policy, do the following:
Start the local group policy editor in Windows: Start -> Run -> gpedit.msc
[image: ]


Local group policy editor starts.
Select the path in the area on the left: Local computer policy -> Computer configuration -> Administrative templates -> Windows components -> Remote desktop services -> Remote desktop sessions host -> Remote session environment -> RemoteFX for Windows Server 2008 R2.
[image: ]


Turn on the following settings in the area on the right:
1) “Configure RemoteFX“
2) “Optimize visual experience when using RemoteFX”
3) “Optimize visual experience for remote desktop service sessions”
Do not change the other predefined parameters in the dialog boxes.

[image: ]



Select the path in the area on the left: Local computer policy -> Computer configuration -> Administrative templates -> Windows components -> Remote desktop services -> Remote desktop sessions host -> Remote session environment.
(This is the folder superior to the one selected beforehand.)
[image: ]



Turn on the following settings in the area on the right:
1) “Use hardware graphics adapters for all remote desktop services sessions”
2) “Configure compression for RemoteFX data”
Do not change the other predefined parameters in the dialog boxes.
Restart the host to apply the new local group policy settings. Afterward, you can use the GPU of the host.
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			Task:

You have installed Allplan on several workstations in the network and now additionally want to work on this shared network drive with Workgroupmanager.



Notes:

Before making this change, it is essential to make a complete data backup on the server and on all workstations. 
The conversion may only be carried out within one version, i.e. if necessary, the upgrade to the same version should be carried out first and only after the upgrade has been completed should the conversion described here be carried out.
Please ensure in advance that your license contains the "Workgroup manager" option or has been updated accordingly. Otherwise Allplan cannot be started after the conversion.  


Response:

	Exit Allplan on all workstations. Start the changeover on any workstation in the network. Open the Allplan Diagnostic Tool via Allmenu->Service->Allplan Diagnostics. Switch to the "Settings" tab.
	
	Under the field "Workgroup Settings" check the box "Workgroup Manager" and confirm with "Set". Confirm the two messages stating that STD and PRJ already exist and will not be copied with "Yes". The first workstation is now converted.
	
	This window user has been created as Allplanuser in the workgroup manager environment as a user with administrator rights. Now all users should be added to the workgroup manager via:

Allmenu -> Workgroupmanager -> Manage users -> Right click -> Create user.

Under "User name", a freely selectable Allplan user name with a length of up to 8 characters can be assigned.

Under "Windows user name", the user name that the user uses when logging on to the computer must be specified. 

Important: If the user logs on to the computer via a domain, this must also be specified under "Windows user name", e.g.: DOMAIN\User. Under "User group" the administration right can be granted: Administrator" must be selected in the drop-down menu. Existing users can also be given the administration right later.
	
	If all users have been added you can ad the remaining workplaces  by going on each workstation and adding Workgroup Manager under Allmenu->Service->Allplan Diagnostics->Settings the checkbox "Workgroup Manager" can be set and confirmed with "Set". 



Important: 

If the check mark at "Workgroup Settings" cannot be activated, it is because the central file storage folder "Net Path" is not entered UNC compliant.  (e.g.: \\Servername\ nemdaten\2022). Change this if necessary. Under "Browse" the UNC name of the new server (e.g.: \Servername) or the complete path (e.g.: \Servername) can be entered in the browser above. 
(e.g.: \\Servername\ nemdaten\2022) and confirm with Enter. Select your central file storage folder and confirm with "OK".
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			Question:

How can the complete setup be downloaded from version Allplan 2023?


Response:

As of version 2023, Allplan is installed via Minimal Installer, which downloads only those components that are actually required for the installation case.
If, for example, the complete installation package with all optional components is required for rolling out the setup, it can be downloaded via layout mode.

To do this, run the setup with the command line parameter "layout" and the desired download path.
To do this, download the installation package from Allplan Connect as usual. 
Create a folder locally, e.g. C:\AllplanSetup. Unpack the installation package and copy the Allplan_2023_x_x_Installer.exe into this folder.
Then start the command prompt or Windows PowerShell in the path of the already downloaded installation exe. (e.g.: Allplan_2023_0_0_Installer.exe).
Run the installation with the parameter.
The syntax is as follows:
[PathSetupExe] -layout [PathDownload].

Example:

C:\AllplanSetup\Allplan_2023_0_0_Installer.exe -layout C:\AllplanSetup\.

After starting the setup using this parameter, the installation progress window appears as usual. However, no installation is performed.
The successful download is confirmed accordingly in the dialog after completion.

The setup can now be executed by double-clicking the already existing installation.exe (e.g.: Allplan_2023_0_0_Installer.exe). 
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			Question:

Although the server is not connected with the Internet, I would like to activate the license with the Product Key for the license server. What can I do? 

Information:

The easiest way to activate and return Allplan licenses is to do this online. In other words, the server has Internet access. However, you can also activate your license on a computer without Internet access (offline licensing). 

Requirements for activating a license offline:
	You have a valid Product Key.
	The license server is installed on the server. At least license server 2016-1-5 is installed.
You can find detailed information on the version (Build-ID) at bottom on the left in the License Settings program.
	You have another computer with Internet access.


Important: Activating a license offline involves two steps. In addition, you need to upload a receipt file so that you can return the license offline later.

There are the following basic steps:
	Creating and uploading the license request file
	Downloading and importing the license update file
	Creating and uploading the receipt file


If you have several license server licenses, you need to do this for each license. 

The online computer uses the following web page:
http://lc.codemeter.com/59885/depot/index.php



Note:

As both the license file and the receipt file are saved with the name of the container number by default, it may happen that you mix up these two files. Thus, we strongly recommend that you use meaningful names for the files. For example, include the word “license” in the name of the license file and “receipt” in the name of the receipt file. 
This is particularly important if you want to activate several licenses offline. 


Answer:

Activating licenses offline

To activate licenses, use CodeMeter Control Center.
Start CodeMeter Control Center.
To do this, use the Windows start menu and select CodeMeter -> CodeMeter Control Center. An an alternative, go to the Windows search box and type Codemeter. 

Select the empty Allplan CM6container (long number starting with 130; gray symbol).
If the container is not available, save the file attached to the C:\Program Files\Allplan GmbH\License Settings folder. Then open this file using the shortcut menu. This imports the empty container to CodeMeter Control Center. 

Select the new, empty Allplan CM6 container and click Activate licenseon the right. Select Create license request. Create a *.WibuCmRaC file for this container. 


Take this file to a computer that is online. Go to the following web page: 
http://lc.codemeter.com/59885/depot/index.php

Enter your Product Keyin the “Ticket” line and click Next. You can now see your license. Click Activate license.

Next, select the Fimcode 6000100area on the right.

You can see your license with all available updates. Make sure everything is selected. Click Offline License Transferat the bottom on the right.

You can now upload the *.WibuCmRaC file (Browse....) by clicking Upload license request now. This creates your license, which you can download by clicking Download license update file now. Install this license on your server.

To do this, open CodeMeter Control Centerand click File -> Importlicense.


The activated license is now visible in the License settingsand can be used for the Allplan clients.


Finally, upload the receipt file.
To do this, open CodeMeter Control Centeragain and select the new Allplan CM6 container (with the number 130-XXXXXXX).

Then click License update -> Next -> Create receipt. 
Create the receipt file for this container. 
Upload this receipt file using the web page. 

Take this file to the computer that is online. Click Nexton the web page.
If you have already closed the web page, use the link given above and enter your Product Key once again. Then select Continue with license transfer.
Select the receipt file and click Upload receipt now.
Click OKto confirm. This completes license activation.


Note:
After you have activated the license on the server, proceed as described in “Installing and configuring the license server”. You can find this guide here:
https://connect.allplan.com/en/faqid/20150618084450.html.


Returning licenses offline
You can return licenses in the same way:
	Creating and uploading the license request file
	Downloading and importing the license update file
	Creating and uploading the receipt file
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			Question:

What can I do if Allplan starts as a viewer only and I have to install a new hardlock driver? 



Answer:

Install the latest hardlock driver.

How to install:

Use the following link to download the driver:

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

The driver for  Windows 7 and 8.1 is in the following folder.
/Download/Allgemein/Dongle/

If you are using Windows 10 then use the driver under the folder:
/Download/Allgemein/Dongle/Win10

Extract and save the 'haspdinst.exe' file to any folder, for example, c:\drivers. Then open the command prompt: 
Right-click Start (Windows button) -> Command Prompt (Admin) 
Switch to the folder where you saved the file. To do this, type in "cd c:\drivers".

To remove the old drivers, enter the following command:
haspdinst   -fremove
Next, install the new driver:
haspdinst   -install


Note: 

If you use a parallel hardlock, read the following instructions: 
https://connect.allplan.com/en/faqid/20121011092418.html
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			Task:

In a network installation, in addition to the program folder located locally on the respective workstation computer, there is a central file storage folder on the data server via which all users can access the office standard and all projects.

How is a new installation of several Allplan workstations with a central file storage on a dedicated server carried out?
What are the requirements?
How is the workgroup manager installed if the license includes it?

1. Preparation

Server operating system or system requirements:

When selecting the data server to be used, please refer to our system requirements. We recommend 
Windows Server 2022. Also check whether the system requirements are met on the clients and perform a system test on them. 
The system requirements and system test can be found here: https://connect.allplan.com/support/sysinfo/2022.html

We explicitly point out that NAS (Network Attached Storage) is only supported on the basis of Windows Storage Server.
DFS (Distributed File System) with Allplan is not supported; it can lead to crashes, deadlocks and deleted files.

Share structure

Allplan works with UNC path. This means that for a network installation, the central file storage on which Allplan 2022 is to be installed must have a folder that is shared by all computers with full access. 
Before installing Allplan, create a folder on the server (e.g. Data) and share this folder with everyone with full access (e.g. as Data). Create an Allplan subfolder under it. (e.g., \Server\Data\Allplan). Point to this path during installation.

Allplan Download: 

Download the version Allplan_2022-X-X.zip as an installation package. You can do this via Allplan Connect at 

https://connect.allplan.com/en/support/downloads.html

or from our Webdrive at the following link:

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

The current full download is located in the folder /Allplan/2022


2. Installation on the first workstation:

Log on as administrator on the workstation where Allplan 2022 is to be installed.

Double-click AllplanSetup.exe in the folder that you used to unpack the installation package.
Confirm the welcome screen with Start setup. Confirm the terms of the software license agreement displayed in the following License Agreement dialog box by clicking Agree.
On the General tab of the Settings dialog box, select the country-specific settings to be installed under Select country and the language for the Allplan user interface under Select language.

Note: The country and language that are set for the operating system on the workstation in question are suggested. If the country and/or language are not recognized, English is used. Please avoid selecting unnecessary countries or languages, as this will greatly increase the data volume to be installed. 

Now select the target paths in which the programs and files of Allplan 2022 are to be installed.

Program folder: Specify the folder for the program files. Normally, it is not necessary to change the folder suggested here. In any case, the program files must always be installed locally on each workstation.
Central file storage folder: Specify as the central file storage folder the folder created and shared on the data server as described in section 1. (e.g. \Server Data File Folder).

Click Install. The installation of Allplan 2022 is started.

Note: If the installation could not be completed successfully, you will receive a corresponding message. In this case, you will find the file Error Report of Allplan_Installer.zip in the folder C:\Users\<username>\AppData\Local\Temp. The file contains important information that you can pass on to ALLPLAN GmbH Technical Support if you need to contact them.

In certain cases, you will be prompted to restart the computer after completing the installation of Allplan 2022. In this case, restart the computer and log in again after the restart as the local administrator or as a user with administrator rights.


2a. Installation with the Workgroup Manager option
(If your license does not include this option, go to step 3).

If your license includes the Workgroup Manager option, please proceed as follows before installing the other workstations. 
Start Allplan 2022 once immediately after installing the first Allplan workstation in the network and then stop it again. Then activate the workgroup manager directly as follows.

To do this, start Allmenu 2022 on the first computer.
Call up Allplan Diagnostics. Allmenu->Service->Allplan Diagnostics 
In Allplan Diagnostics, select the Settings tab and check "Workgroup Manager" in the Workgroup Settings area. Click on Set. The workgroup manager is now activated.

If the check mark for "Workgroup Settings" cannot be activated, it is because the central file storage folder "Net Path" is not entered in a UNC-compliant manner.  (e.g.: \\Servername\Daten\Allplan). Change this if necessary. Under "Browse" the UNC name of the new server (e.g.: \\Servername) or the complete path (e.g.: \Servername) can be entered in the opening browser. 
(e.g.: \\Servername\Daten\Allplan) and confirm with Enter. Select your central file storage folder and confirm with "OK".
Even if the central file storage folder is located locally on the same computer, the path must be entered as UNC address!

Exit Allplan Diagnostics by clicking Close.
Allmenu now additionally contains the Workgroupmanager menu.


2b. Creating the Allplan users

As a result of the initial installation, the installing Windows user is created in Allplan as a user with administrator rights. On the first installed workstation, create all other Windows users of the other workstations as Allplan users in the workgroup manager:

Allmenu -> Workgroupmanager -> Manage users -> Right click -> Create user.

Under "User name", a freely selectable Allplan user name with up to 8 characters in length can be assigned.
Under "Windows user name", the user name that the user uses when logging on to the computer must be specified. 

Important: If the user logs on to the computer via a domain, this must also be specified under "Windows user name", e.g.: DOMAIN\User
Under "User group" the administration right can be granted:
Administrator" must be selected in the drop-down menu. Existing users can thus also be granted administration rights at a later date.


3. installation on the other workstations

Now install Allplan 2022 on all the other workstations as described above under "2. Installation on the first workstation". Enter the folder created and released in step 2 for the central file storage on the data server as the central file storage folder.  (e.g. \Server DataAllplan).

Note: If the Workgroup Manager was activated after the first workstation was installed (see step 2a.), it is automatically activated on all other Allplan workstations installed in the same network by selecting the Central file storage folder.



Hint:

Detailed installation instructions can also be found at the following link:

https://help.allplan.com/Allplan/2022-0/1031/Installation/index.htm#286.htm
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Allplan from version 2011

Parts of Allplan 2011 have been reprogrammed and are completely new. Allplan uses a graphics library, which has been developed especially for CAD programs and visualization tasks. Depending on the data type and application, the display speed of Allplan is much higher than that of earlier versions, and refresh operations are considerably shorter. What's more, you can create hidden line images in real time.
This new technology is not a one-to-one implementation of the software-based solution in the previous version. Instead, a hardware-based approach is used. When it comes to data processing, the graphics card takes on much of the work. The different behavior of these two technologies that may occur in some parts is inherent. Therefore, the resulting display and refresh operations may differ slightly from what you are used to.



General graphics card requirements for Allplan 

To fully exploit hardware acceleration capabilities, you require an Open GL 2.0 and DirectX10 (chip-based) compatible graphics card with 512 MB or more memory. Although Windows XP does not support DirectX10, Allplan only requires the chip-based support of the graphics card to manage the graphics library. OpenGL 2.0 is used in 2D and in visualization windows. These changes employ the latest technology in graphic display, so selecting a capable graphics card, and using the proper drivers is essential.

For more information on graphics card specifications, go to:

http://en.wikipedia.org/wiki/Comparison_of_AMD_graphics_processing_units
http://en.wikipedia.org/wiki/Comparison_of_NVIDIA_graphics_processing_units#Quadro)



Professional graphics cards versus Consumer-Level cards 

Graphic card manufacturers typically have different product lines targeted for "gamers" and "professional users". While the hardware setup is very similar in case of both cards, there are key differences in their firmware and driver. "Consumer-Level cards" (such as Nvidia GeForce and AMD/ATI Radeon) are optimized for 3D games and technologically designed for DirectX10, as speed is more important than image quality.
Typically a 3D model in a game contains a low number of polygons with textures applied to them, while in CAD applications polygon count is high, and the image quality of wireframe models or shaded models is more important than navigation speed. Also, professional cards' memory usage is optimized for using multiple application windows, while in gaming this is not relevant.
Another key difference between the two product lines is the way they are delivered and supported. Professional cards (such as Nvidia Quadro and AMD/ATI FireGL/PRO) are built according to the video chip manufacturer's references,  so you can always be sure that the driver delivered by the video chip manufacturer (such as Nvidia or  AMD/ATI) fits your card.
The manufacturers of Consumer-Level cards (such as ASUS, Sapphire, Gigabyte, PNY and so on) may diverge from the chip manufacturer's references,  so their drivers may not be compatible with the chip manufacturer's reference driver.  Also, the product life cycle and driver release cycles are much shorter in case of gaming cards, usually 6 months up to 1 year at most and a 1-year warranty period maximum.

Example: comparison of graphics cards


	 	Consumer-Level cards
	Professional graphics cards / workstation

	Products	Radeon
	FireMV
	FireGL/Pro
	Mobility FireGL/Pro

	Markets		Private customers: desktop systems and notebook systems

		Corporate desktop systems

		Corporate CAD and DCC desktop systems and notebook systems 


	Applications		Home/office publishing,  productivity, multimedia, games, Internet

		Finance, clearance, logistics, airport information displays

		CAD/CAM/CAE, AEC, DCC, GIS, MI, visual simulation, scientific research/imaging


	Certification		WHQL certification

		Industrial applications
	WHQL certification

		Professional 3D applications
	WHQL certification


	Operating
systems		Windows 98SE / Me / XP
	Windows Vista,
Windows 7

		Windows XP, XP64,Vista, Vista 64, Windows 7, Windows 7 64
	Linux


	Drivers		Optimized for DirectX
	Basic Open GL

		Optimized and designed for DirectX
	Optimized and advanced Open GL


	Life cycle		Available for 1 year on average

		Available for 2-3 years on average


	Support		Basic, private customers

		Direct access to dedicated support by trained technicians


	Warranty		1 year

		3 years with replacementof components






Professional graphics cards versus Consumer-Level cards

Professional graphics cards differ considerably from "Consumer-Level cards" for private users with regard to specific market segments with special requirements:

	Extensive application tests and certifications with CAD providers
	Optimized and advanced support for API as well as further developments
	Longer product life cycles and availability
	Direct product support
	Longer warranty period



Nemetschek Allplan GmbH cooperates with Nvidia und AMD to test graphics card drivers for the Nvidia FX Quadro/ Quadro and AMD/ATI FireGL/ Fire Pro series. These product lines are tested, certified and recommended for Allplan by Nemetschek Allplan Systems GmbH. 

For more information on certified graphics cards, go to:

https://connect.allplan.com/support/tested-graphics-cards.html

There are four different categories and areas:


	Graphics card	Application	Quality tests	Status
	 	 	 	 
	Gaming graphics cards	3D Games	Tested / not tested	Not recommended
				
	Professional graphics cards	3D basis	Certified and recommended	End of life
				
	Professional graphics cards	3D performance	Certified and recommended	End of life
				
	Professional graphics cards	3D high performance	Certified and recommended	End of life




Recommended graphics cards for laptops (Windows)

For reasons detailed above, we cannot recommend any specific card and driver combination for laptops. However, there are professional graphics cards available for high-end laptops such as NVidia FX Quadro & Quadro NVidia "M" or AMD/ATI FireGL & FirePro "Mobility".
These graphics cards are just as good as their desktop counterparts.
Laptops with Consumer-Level cards have been tested only briefly and cannot be recommended. We have had bad experience with on-board Intel graphics cards.



Graphics cards drivers for Apple Macintosh

Since Macs come with a default graphics card (on-board or gaming), and the drivers are bundled with system updates, we cannot recommend a specific card.
Graphics cards for MacOsX 10.6 (Leopard) or later and Boot Camp support Open GL 2.0 and DirectX10. Currently, there is only one series that is equipped with a professional graphics card: Mac Pro with NVidia FX4800 for Mac. 


Notes for Allplan and Macintosh:

	There is no provision for a direct installation under Macintosh.
	Access to Windows must be straight from the Boot Camp installation.
	For performance reasons, Parallels Desktop cannot be used in conjunction with Nemetschek Allplan.


We kindly ask you to understand that Nemetschek Allplan cannot provide support for Boot Camp installations.



Installing graphics cards drivers (Windows)
Graphics cards only work properly if they have a hardware provider supplied driver (not system built-in driver) installed correctly.  It may happen that remnants of a previous installation interfere with the current driver installation. If you experience display issues with the drivers listed below, please "clean-install" the driver again. "Clean-install" means removing all previous driver files before installing a new driver. Unfortunately, a simple uninstall may not efficiently remove all components of a driver. There are tools that can do it, like ATI's cat uninstaller or third-party tools like driver cleaner or driver cleaner pro 1.5.


Graphics card drivers for laptops (Windows)

In most cases, graphic card drivers for laptops are supplied by the laptop manufacturer, and graphic card provider supplied drivers will not install on laptops. This makes it practically impossible for us to test laptop graphics cards. If you are experiencing display issues with your laptop, and your supplier does not offer you a driver update, you might try - at your own risk - to tweak a desktop driver to work on your laptop. Note that this is obviously not encouraged by your laptop supplier.
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			Question:

How can I temporarily borrow a license for a client from the license server? 



Answer:

To borrow a license, do the following:

Notes:
You cannot borrow licenses on the license server. You can do this only at the clients. 
You can only borrow and return a license if the client is connected with the license server.
Computers that are not on the company network must use a VPN connection to access the server.

At the client:
	Open the 'License settings' dialog box: Services application -> Utilities -> License settings.
	Click License selectionon the left. Then click the license you want to borrow so that this license is highlighted in blue.
	If this license is a license server license, the Todayand Borrowbuttons in the 'Borrow license for:' area are no longer grayed out.
	The Todaybutton always shows the preset period of time. The default setting is Today. If you want to change the period of time, click the Todaybutton. You can then choose from various options. 
Note: When you select 'Today', the license will be available again for all Allplan users on the server tomorrow.
When you select a number of days, borrowing will always be valid for 24 hours. For example, you borrow a license for 1 day and borrowing starts at 3 o'clock in the afternoon, the license will not be available on the server until 3 o'clock in the afternoon. The same applies to selecting days on the calendar.
	After having specified the correct period, click Borrowto borrow the license at once.


You can immediately see the borrowed license in the license selection below your computer name. Click the green information button to get details about this license. For example, you can see when the borrowed license will automatically be returned to the server.

	If you want to return the license to the server before the time period expires, click the license again so that it is highlighted in blue. The Return licensebutton is now available. Click Return licenseto immediately return the selected license to the server.
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			Question:

How can I make several projects available to users when Workgroup Manager is installed?



Answer:

You can make several projects available to a user or define a user as the project owner of several projects.

Do the following:

First, log in as the Allplan administrator.
If necessary, set up an Allplan user for the new Windows user: Services application -> Workgroup Manager -> Configuration -> Add a user
(Allplan 2014 and later:Services application -> Workgroup Manager ->Administer users)

Start Allplan and then ProjectPilot by clicking 
File -> ProjectPilot

Open the Projects folder in the area on the left.
You can see all the projects in the Contents of "Projects" area on the right.

a. Making several projects available to users:
In the area on the right, select the projects to which you want to add users or from which you want to remove users (CTRL or SHIFT key or use a selection rectangle).

Click one of the selected projects with the mouse button. On the shortcut menu, click 
Add / remove authorized users...
The Add / Remove Authorized Usersdialog box opens. 

Select the users you want to add to or remove from the selected projects.
Note: 
The user list displayed only helps you select users. It does not list all the authorized users currently assigned to projects. 

Click Addor Remove.
This adds or removes the selected users to or from the selected projects. Whether users you have already added to a project are added again is irrelevant. The same applies if you remove users you have never added to a project.

b. Defining a project owner for several projects
In the area on the right, select the projects for which you want to define the owner (CTRL or SHIFT key).

Click one of the selected projects with the mouse button. On the shortcut menu, click 
Change project owner...
The Define Owner dialog box opens. 

Select the user you want to define as the owner of the selected projects.
Note: The user list displayed helps you select users. You can define only one user as the owner. 

Click OK.

c. Defining a project owner for a project or making a project available to several users(also applies to earlier versions):
In ProjectPilot in the area on the right, click the relevant project with the right mouse button. On the shortcut menu, click Properties.
The Properties for <project name>dialog box opens. Switch to the Security tab and define the owner and the authorized users.



Note:

You can add or remove project users or define the project owner only if the projects in question are in the current Allplan format.
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			Question:

How can I start Allplan in logging mode?



Answer:

In order to analyze problems, you can run Allplan in logging mode. Allplan then logs what it is doing.

In general, you can activate this mode by generating a support request with Hotinfo and selecting the following option:
02. Inquiry with Allplan logging

However, this may not be possible in rare cases. If this is so, you can run Allplan in logging mode without generating a Hotinfo support request.
Exit Allplan and open the Services application.
Set the following:
Services application -> Service -> Allplan logging (trace) -> Write to "Allplan.out" file(up to version 2012: Write to "stderr.out") 

Now the following log files are created whenever you start Allplan:
Allplan.out  (up to version 2012: "stderr.out"), Adm_info.outand ToolBox.out (the last two files are only created under certain circumstances; so they do not necessarily have to exist).
The files are in the local Allplan folder. 
The quickest way to this folder: 
Services application -> Service -> Windows Explorer -> My own temporary CAD data (TMP)
(Up to Allplan 2012: Services application -> Service -> Windows Explorer (program folder))

Send these files to Technical Support along with a Hotinfo support request (question 01: general inquiry), if necessary. 

Note:
We recommend that you turn Allplan logging off again.
To do this, exit Allplan and open the Services application.
Set the following:
Services application -> Service -> Allplan logging (trace) ->Turn off
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			Question:

How can I use Allplan to create PDF documents (Portable Document Format) that can be opened and viewed using PDF viewers such as the free Acrobat Reader? 



Answer:

You can export PDF files directly from Allplan. 
In addition to the design, bitmap areas and text, the direct export tool transfers layers, OLE objects, transparency and gradients.
Of course, you can also use external programs such as Adobe PDF and FreePDF to create PDF files. However, these programs do not provide all the options mentioned above. For example, transparency is not transferred.

Allplan provides the following options for exporting PDF data:

1. using the layout editor: 
Create -> Plot Layout  -> Export PDF Data

2. using the print preview: 
Click the Export PDF Data icon in the toolbar at the top

3. exporting 3D PDF files from the animation window:
You can create a PDF file from the animation window. This file contains the 3D model displayed in the animation window.
This option is not described any further in this FAQ.


General settings:

When exporting PDF data, you specify the file name in a dialog box, where you can also make basic settings for the PDF file:
	Resolution (in dpi)
	Document size (paper size (with margin) or printable area (without margin))
	Entire layout content
	Archiving format PDF/A 1a
	Export layers
	Embed TrueType fonts
	...
	Add to file (first select an existing PDF file in this dialog box and then select this option -> the PDF file is attached as a new page to the existing file)
	Grayscale (version 2011 and later)
	Open file with associated application (should be selected. After you have created it, the PDF file automatically opens in this application so that you can check it.)



Note on the page format (new in Allplan 2011):

In Allplan 2011 and later versions, you set up a page in Allplan. The page size should be used as the size for the PDF file.
You need to exactly define the size you require for the page.

To use the page size for exporting the PDF file, select the following options:
	Select 'Paper size (with margin)'.
	Clear the 'Entire layout content' check box, if necessary.



Notes on 1. settings in the Plot Layout module:

You can make advanced settings in the "Plot Layouts" dialog box. 
The following settings are used for exporting PDF data:
	Plot elements / options (Selection tab)
	Paper format and orientation (Output tab); see the above notes on the page format.
	Resizing: Resizing factor, resize pen thickness and rotation by 90° (Settings tab)
	Pen and color assignments... (Settings tab)
-> Line thickness for monochrome output and line colors for color output
-> Line display in color, black or using shades of gray (can only be changed when you select a color printer beforehand)
-> Gamma correction
	No pen optimization/ Use one pen only (number:)
	Plot profile (Settings tab)




Notes on 2. settings in the print preview:

The PDF file is exported as it is currently displayed on screen.
You can make the settings that are used for the "Print" tool directly in the print preview (Display tab in the Print Preview Options).



Notes:

To export PDF data in color, you need to install a printer driver that supports color and select this driver in the layout before you start exporting the PDF data.
It is advisable to install a printer driver for a large-format color plotter such as an HP DesignJet even if your office is not equipped with a large-format printer/plotter. 
[Install as a local printer/ without plug & play, port: FILE, do not share the printer, do not print a test page.]
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			Question:

Why is it not possible to clear the check box for 'Find license server automatically' and why can't I enter an additional server name? These functions are grayed out.


Answer:

This problem is caused by Windows access rights. Only administrators can change these options.

Installing Allplan:
If this problem occurs during Setup and you cannot select a license, start by installing Allplan as a viewer.

Granting permissions later:
Assign full control to the users. 
Local permissions prevent them from accessing the following file: Lic3LM.ini  

Check whether the users have full control of the following folder:
Click folder with the right mouse button -> Properties -> Security -> Edit -> select the user - > grant full control

C:\ProgramData\Nemetschek(hidden file)

Open the 'License settings' dialog box: Services application -> Utilities -> License settingsYou should now be able to clear the check box and enter additional server names.
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			Question:

How can I make several computers use the same license server settings?



Answer:


The settings are saved in two files:

	Lic3LM.ini in C:\ProgramData\Nemetschek
	Lic3.ini in C:\Users\[user_name]\AppData\Roaming\Nemetschek. To access this user-specific file, use %appdata%/Nemetschek, for example.



Lic3LM.ini in C:\ProgramData\Nemetschek:

This file includes information on server selection, that is to say, the server name and information on whether the ‘Find license server automatically’ option is selected.

What do the values mean?

	UseWibuList=yes: find license server automatically
	UseWibuList=no: do not find license server automatically
	Server=[server_name]: name of license server




For example:

[Environment-1]
UseWibuList=yes
Server=Server01

In this example, the computer is connected with the ‘Server01’ server and the ‘Find license server automatically’ option is selected. 


Lic3.ini in C:\Users\[Benutzername]\AppData\Roaming\Nemetschek:

This file includes information on which license is preferred or blocked.

What do the values mean?

	0: license is not selected
	100: license is preferred
	-100: license is blocked



For example:

[Viewer-1] 
view=no
[ConfUi-1]
Page=Select
[Favourite-1]
128-7822048:23:5000505=0
128-7823287:24:5000505=100

In this example, seat 24 is selected (preferred) and seat 23 is not selected.


Note: 

Use the Services application -> Utilities -> License settings to create these two files with the required settings on one computer. 
You can then transfer these two files to the other computers, thus avoiding incorrect entries.
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			Question:

My computer does not have Internet access, but I would like to activate the license with the Product Key. What can I do?


Information:

The easiest way to activate and return Allplan licenses is to do this online. In other words, the computer has Internet access. However, you can also activate Allplan on a computer without Internet access (offline licensing). Offline licensing is particularly useful if some Allplan computers in your office do not have Internet access and do not use a license server either.
If the computer without Internet access and the computer with Internet access are neither close to each other (for example, the computer in the office hasInternet access, but the computer at home does not haveInternet access) nor connected with each other (for example, using LAN), offline activation is not very suitable, as you have to access both the computer with Internet access and the computer without Internet access.

Requirements for activating a license offline:
	You have a valid Product Key.
	You have installed Allplan on the computer without Internet access (for example, as a viewer).
	You have another computer with Internet access.


Important: Activating a license offline involves two steps. In addition, you need to upload a receipt file so that you can return the license offline later.

There are the following basic steps:
	Creating and uploading the license request file
	Downloading and importing the license update file
	Creating and uploading the receipt file


The online computer uses the following web page:
http://lc.codemeter.com/59885/depot_151/index.phphttp://lc.codemeter.com/59885/depot/index.php


Note:

As both the license file and the receipt file are saved with the name of the container number by default, it may happen that you mix up these two files. Therefore we strongly recommend that you use meaningful names for the files. For example, the name could include the name of the computer and the Product Key or the words “license” and “receipt”.
This is particularly important if you want to activate several computers offline.


Answer:

A: Activating licenses offline

To activate licenses, use CodeMeter Control Center.

Start CodeMeter Control Center.
To do this, use the Windows start menu and select CodeMeter -> CodeMeter Control Center. An an alternative, go to the Windows search box and type Codemeter.

You can find the container numbers in the ‘License’ area.
If you have a stand-alone license, the name of this container is Allplan GmbH and its number is 327XXXXXXX.

Select this container and click Activatelicense on the right. Select
Create license request. Create a *.WibuCmRaC file for your container.

Take this file to a computer that is online.
Go to the following web page:
http://lc.codemeter.com/59885/depot/index.php

Enter your Product Keyin the “Ticket” line and click Next. You can now see your license.
Click Activate license.

You can see your license and all available updates, which should be selected. Click Offline License Transferat the bottom on the right.

You can now upload the *.WibuCmRaC file (Browse....) by clicking Upload license request now. This creates your license, which you can download by clicking Download license update file now. Install this license on your computer.

To do this, go to CodeMeter Control Center and click File-> Importlicense.


You can see the activated license in the Services application -> Utilities -> License settingsand you can now use this license for Allplan.


Finally, upload the receipt file.
To do this, open CodeMeter Control Centeragain and select the new Allplan GmbH license with the number 128-XXXXXXX.

Then click License update -> Next -> Create receipt.
Create the receipt file for this container.
Upload this receipt file using the web page.

Take this file to the computer that is online. Click Nexton the web page.
If you have already closed the web page, use the link given above and enter your Product Key once again. Then select Continue with license transfer.
Select the receipt file and click Upload receipt now.
Click OKto confirm. This completes license activation.




B: Returning licenses offline

You can return licenses in the same way:
Start CodeMeter Control Center and select the container with the license (Allplan GmbH with the number 128-XXXXXXX). Then click License update -> Next -> Create license request.
Here, too, create a *.WibuCmRaC file for your container.

Take this file to a computer that is online.
Here, too, go to the following web page:
http://lc.codemeter.com/59885/depot/index.php

Enter your Product Keyin the “Ticket” line and click Next. You can now see your license.
Click Move license.
Click Offline License Transferat the bottom on the right.
You can now upload the *.WibuCmRaC file (Browse....) by clicking Upload request now.
Then click Download license update file now. Download the file and import it. To do this, go to CodeMeter Control Centerand click File -> Importlicense.

Then create a receipt by clicking License update -> Next -> Create receipt.
Upload this receipt file using the web page.
To do this, click Nexton the web page.
If you have already closed the web page, use the link given above and enter your Product Key once again. Then select Continue with license transfer.
Select the receipt file and click Upload receipt now.
Click OKto confirm. This completes license activation.

The license is now available again and can be used on another computer.
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			Question:

You want to include a computer in the Allmenu via Workgroupmanager, but no network environment is displayed and no result appears when you enter the computer name in Search. How can the computer still be included?  



Answer:

All computers included in the Workgroupmanager are stored in the data.cfg on the server in the central file storage request.
The Allmenu window shows the exact path of the "central file storage folder". 

e.g. \\SERVER\data\Allplan
Go via Windows Explorer to the central file storage folder in the NET folder and open the file data.cfg (e.g. with the editor)

The content of the file looks like this 
SERVER \data\Allplan

(So far no computer has been included and therefore there are no further entries in this example)

Here you can enter the new path of the computer to be recorded 
Simply enter the computer name, spacebar, shared folder, subfolder as a new line.
Enter only your simple host name here, not the FQDN name (first name only, without periods and other additions)

Please make sure that all entries are flush with each other. Please do not remove the space bars in existing entries and also insert a space bar after the host name when entering, these are important.

So it looks like this 

SERVER \data\Allplan
COMPUTERNAME \Nemdata\Allplan

Save the file. 

As a result, the computers in the workgroup are displayed in the Allmenu/Services application under Workgroupmanager - > Administer projects and computers and can now be checked out. 
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			Question:

I cannot activate Allplan. When I enter the Product Key, the "no Internet connection" message appears even though the computer is connected to the Internet. Which ports are required? Are there any settings for the proxy server?


Answer:

License activation accesses the internally used URLs

https://lc.codemeter.com/59885/gateways/getLicenses.php and 
https://lc.codemeter.com/59885/gateways/getTicketInformation.php.

Make sure the proxy server does not block these URLs. 
Try to activate the license again.
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			Question:
	Why can't I create elements?
	Why can't I move a drawing?
	Why are elements not created correctly?
	Why does the program crash when I import a DXF file from the land registry office?
	Why is the outline of a circumscribed area not detected correctly?
	Why can't I calculate shadows?
	Why are elements not displayed correctly in animation?
	Why are parts of dimension text missing?
	Why do the contents of the screen suddenly rotate?
	Why can't I get a preview when I move or copy elements?
	Why are areas not calculated correctly?




Finding the reason for these problems:

Check whether an offset is set in the project settings (File -> New Project, Open Project-> select the project and open the shortcut menu -> Properties; Allplan 2009 and earlier: Tools -> Options ->Advanced Draft -> Settings). If there are offset coordinates, clear the check box.

Select Tools -> Measure(->)Coordinates.
Click in the middle of the drawing in plan view.
If there are very large values (for example, x/y/z greater than 5000 m), you have found the reason for these problems.

The system has problems calculating and displaying data with very large coordinates. The more data you have with very large coordinates, the greater this effect.



Solution:
 
	Click Tools -> Options... -> Desktop environment -> Generaland select Optimize working with large coordinates(Allplan 2009 and earlier: Tools -> Options -> Global Options -> Miscellaneous tab -> Optimize working with large coordinates). After this you must restart Allplan. Otherwise, this setting has no effect.

This is a user setting you must define separately for each user.
	Usually, the best solution is to move the data towards the Allplan origin. Use the "Move" tool. When Allplan prompts you to specify the target point ("To point"), select Global point in the dialog line. You can find detailed information in the help for Allplan. Look for the Global pointtopic.
	 



Note:

If the data are still not displayed correctly, do the following:
Exit Allplan -> Services application-> Service -> Hotline Tools-> cleanup -> start Allplan.
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			Question:

How can I move the "central file storage folder" of an Allplan installation to a new server?



Note: 

The procedure described below is not approved by Allplan. Do this at your own risk. 
You are strongly advised to clarify all issues in advance. 
If you are not sure what to do, we recommend that you uninstall and reinstall Allplan or consult technical support.
Always copy a file before you change it.



Answer:

A. General information
Copy the "central file storage folder" from the old server to the new server. 
You can find this folder under a shared folder.
Create the same folder structure and share (including the share name) on the new server, making things easier for you. However, this is not mandatory.


B. Allplan installation with Workgroup Manager

1. Changes on the server
Enter the new server name in the following files on the new server. You can find these files in the NET folder, which is a subfolder of the central file storage folder. You can open the files in an editor and edit them there.

data.cfg
· Enter the server name in CAPITAL LETTERS (also applies to user.cfg and project.dat!), for example, SERVER.
· Do not delete the blanks after the server name.
· If the share name or folder name has changed, you need to enter the new name after the blanks.

user.cfg
· Since Allplan 2014 this file is encrypted and is saved in ANSI format
· Open the files with editor. After the = change the server name to new name, use CAPITAL LETTERS (without any blanks).
· When finished click on file in the left top and chose save file as
· File name: user.cfg
· File type: text file (*.txt)
· Encyryption(Coding): ANSI
· Save

Note: if the server name is not shown in user.cfg please contact us again by sending your fuser.cfg and the new server name.

project.dat
· Rename the "project.dat.xml" file "project.alt.xml".
· Then go to step "2. Changes on the workstations". Complete the process for one workstation!
· When you have finished, do the following:
Services application -> Service -> Hotline Tools -> reorg -> Restore project management file -> OK


2. Changes on the workstations
On each workstation, you must adjust a value using the registry editor.

Switch to the following key:


HKEY_LOCAL_MACHINE\Software\Nemetschek\Allplan\'version number'\InstallRoot


In the "NetDrive" value, enter the new server name and the new share name, for example, \\SERVER\Nemdata.
In the "NetPath" value, enter changes in the subfolders, for example, \Nemetschek\Allplan.
Together NetDrive and NetPath define the valid path of the "central file storage folder" on the new server, for example, \\SERVER\Nemdata\Nemetschek\Allplan.


C. Allplan installation without Workgroup Manager
If Workgroup Manager is not installed, use the procedure described in B. You can ignore step "1. Changes on the server".


D. In addition: check the licensing system you are using!

Standalone license:
If you run Allplan using standalone licenses, there are no particular issues to bear in mind. 

Wibu license server:
If you want to use the license server also on the new server, you need to return the license on the old server. Install license server on new server and activate the license on the new server again. You can find detailed instructions at:
https://connect.allplan.com/en/faqid/20150618134224.html


Note: If you want to create an image of the server or virtualize the server, please contact the technical support team.
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			Question:

Allplan is installed so that the projects (central file storage folder) are on the server. Consequently, Allplan requires a stable and permanent connection to the server. How can I prevent the network interface card from interrupting this connection?



Answer:

There is usually a setting in the power management of the network interface card that allows the operating system to temporarily turn off the network interface card if the user has not done anything for a certain time. If this happens while Allplan is running, there is the danger that current drawing files will not be saved correctly on the server. This may lead to damaged drawing files you cannot open any more. 

To prevent this, you can turn off this setting. Please do the following:

Windows 8.1:
Right- click the Start button -> Device Manager -> Network adapters -> double-click the current network interface card -> Power Management tab -> clear the "Allow the computer to turn off this device to save power" check box. 

Windows 7: 
Start -> Control Panel -> Device Manager -> Network adapters -> double-click the current network interface card -> Power Management tab -> clear the "Allow the computer to turn off this device to save power" check box. 

Windows XP: 
Start -> Control Panel -> System -> Hardware -> Device Manager -> Network adapters -> double-click the current network interface card -> Power Management tab -> clear the "Allow the computer to turn off this device to save power" check box. 
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			Question:

How can I move the license server to a new server? 



Answer:
If you activated the license(s) online by entering a Product Key, you can return the license(s) and then use them on a different server. You can return licenses only if the server has Internet access.


Returning a license

To return a license in online mode

	Start the license server by opening the License Settings.
	Click License activationon the left. Then click the license you want to return.
	Click Return license.
	Do this for each license until you have returned all licenses.


You can now activate the license(s) on a different server.


To install the license server on the new server, download the software for the license server from Allplan Connect. 
You can activate a license in online mode only if you have ...
	Internet access
	a Product Key



Installing the license server on the new server

	Start License Server Setupon the new server.
	Click Install.
	Start the license server by starting the License Settingsprogram. Go to the License activationarea, enter your Product Key and click Activate license.
	If you have more licenses for the license server, enter the respective Product Keys and activate the licenses.
	Afterwards, start CodeMeter Control Center.
To do this, use the Windows start menu and select CodeMeter -> CodeMeter Control Center. As an alternative, open Search by clicking the Search button on the Start screen, enter Codemeter and press ENTER. A dialog box opens. Click WebAdmin at bottom right.

Or Enter Localhost:22350in the address bar of your browser.

	Select Settings -> Server -> Access serverin the Network serverarea and click Activate.
	Click Apply.



Configuring the clients

The license server license will be detected automatically on the network; the clients display the license(s) provided by the new server.

Check the license selection in the license settings of the client:
Services application -> Utilities -> License settings -> License selection

Priority: 
Select the check box in front of a license to select this license as a favorite. You can mark as many licenses as you want. Allplan will then prefer these licenses. Click [image: ]
to select one ore more licenses Allplan is not to use. If you do not select any license or if you have selected several favorites, Allplan will automatically use the first free license it finds.

Find license server automatically: 
When you select this option, Allplan automatically detects a license server on the LAN. In some cases, such as VPN connections, Allplan may not be able to detect a server automatically. In this case, you can enter the server manually (see additional server name).
Note:Only the Windows administrator can change this option.

Additional server name:
If 'Find license server automatically' is not active or Allplan has not automatically found a license server, you can manually enter the name or the IP address of the server. If 'Find license server automatically' is active, you can enter an additional server. After having entered the server name, click Updateto see the licenses of the license server. Use semicolons to separate several server names.


Notes: 

You can find detailed information on the license server in the License Settings help (F1 key).

Allplan communicates with the license server via TCP/IP. By default, communication is via Port 22350unless you change the port in CodeMeter WebAdmin.
If a firewall is active on your computer, you must enable port 22350 for TCP and UDP. If the firewall filters in an application-specific manner, you have to enable the CodeMeter.exe license server service. You can find this service in the %Program Files (x86)%\CodeMeter\Runtime\bin Windows folder. Define the CodeMeter.exe service as an exception in the firewall. Some anti-virus programs also include firewall functions. If you are not sure, contact the manufacturer of the anti-virus program.
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			Question:

After crashing, Allplan does not start anymore. When you open license selection in the license settings, you can see the following message: "Cannot find a license for running Allplan." How to solve this problem? 



Answer:
Restart the service:
Start CodeMeter Control Center.
To do this, use the Windows start menu and select CodeMeter -> CodeMeter Control Center. As an alternative, open Search by clicking the Search button on the Start screen and enter Codemeter. 

CodeMeter Control Center -> Process -> Start CodeMeter Service
If the service is running, stop it and restart it. 
[image: ]



The crash causes this problem. The fact that the license is not available is a consequential error.

Note: 

If Allplan crashes often, 
send the following information by email to your Allplan Support:
	An exact description of the last step before the error or crash occurred.
	The error message itself (as a screenshot). To find out how to take a screenshot, look at
https://connect.allplan.com/en/faqid/0001cb36.html
	A support request (Hotinfo) with question 01. To find out how to create a support request, look at
https://connect.allplan.com/en/faqid/20140528094911.html
	The 'Allplan.out' log file. To find out how to create a log file, look at
https://connect.allplan.com/en/faqid/0001a27a.html
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			Question:

Why is it not possible to install IBD planning data?
Why does Allplan not accept my activation code?



Answer:

If you have just installed Allplan or if you have used a trial license until now, start Allplan once with your license so that Allplan saves your customer number.
Make sure you install the correct IBD package.

IBD provides additional wizards you can use in Allplan. However, you have to purchase these additional wizards.
Should you have any questions (costs, use), please contact your sales partner.


Some notes on IBD:

IBD CAD Planning Data(building construction, industrial construction, ...) are wizards you can use in Allplan. Consequently, you can only install these wizards on a computer running Allplan.

IBD Building Components(building construction, building alteration, ... ) build on BCM/Nevaris.
If you use Nevaris, you must install IBD building components on a computer running Nevaris andAllplan.
If you want to use IBD building components for BCM, you must install this package on a computer running Allplan BCM. 
As you can see, it matters whether you are trying to install IBD building components for Nevaris or BD building components for BCM.
You can find both packages on Allplan Connect.


Make sure you download the right package from Allplan Connect.

You get activation codes for the IBD packages you purchase.
You can see your activation codes on Allplan Connect at http://connect.allplan.com/license.
Pay attention to uppercase and lowercase letters in Setup.
You can find the IBD packages on Allplan Connect at
https://connect.allplan.com/de/support/downloads.html
(requires login details for Allplan Connect)

You can filter by version, such as Allplan IBD Version 2016.


Note:

There is no trial license for IBD. This means that you cannot install IBD if you run Allplan with a trial license.

You can install two IBD packages for free. You do not require codes for IBD CAD Basic Planning Data and IBD CAD Building Alteration Data. You can also find these packages on Allplan Connect.
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			1. What is a company network?

As a customer, you can create a "company network" in Allplan Connect.
People who are assigned to your company network also enjoy the functional scope of Allplan Connect. 
As an administrator, you can invite and accept employees to your Allplan Connect company network, but you can also remove people who have already been assigned. You can become an administrator by registering with your customer number and entering your admin key on the Company network profile page.
The customer number is not a mandatory field and can also be entered in your profile at a later date. You will find further information on the customer number when you enter it using the small question mark. 
However, only correct customer numbers can be entered in the "Customer number" input field, or more precisely: only valid customer numbers are saved. If the "Customer number" field is still empty after saving, the number you entered was not valid.
You can find your customer number in the Allplan menu in the "Information" area or in the "?" help function of the Allplan CAD software under "About Allplan".

2. What is an administrator?

The administrator is an employee within an office who is authorised to create an Allplan Connect company network. As an administrator in Allplan Connect, you have extended rights to set up an Allplan Connect company network, invite people, confirm or reject connection requests from people to an existing company network, but also to remove people who have already been assigned to a company network.

3. How do I become an administrator in Allplan Connect?

You can only become an administrator if you are an Allplan customer and confirm your customer number using the Admin Key:

connect.allplan.com/admin/company-connection.html

4. What is an admin key?

The Admin Key is a 16-digit character string. Persons who receive the matching Admin Key for a customer number can become the administrator of the customer-related company network in Allplan Connect.
Each Admin Key is only valid in conjunction with your customer number and can only be used once. If you require an additional Admin Key, you must apply for this and we will send it to you personally.

5. How do I get an admin key and where can I enter it?

You can obtain the admin key in the "Company network" area in Allplan Connect:

connect.allplan.com/support/contact/request-admin-key.html

This can be entered here after receipt:

connect.allplan.com/admin/company-connection.html

6. Can I log in to Allplan Connect without an admin key?

Anyone who is interested in the Allplan software, is already a user or is simply looking for information about Allplan can join Allplan Connect. Registration is free of charge and Allplan Connect users can access all areas even as an interested party.

7. Can there be several administrators in my network?

As soon as another user confirms a customer number using the admin key, this user is also an administrator in the corresponding company network. As an administrator, you have the option of removing any other administrator from the company network. You can request additional AdminKeys here: 

connect.allplan.com/support/contact/request-admin-key.html

If your administrator leaves the company, is on holiday for a longer period or is otherwise occupied, you always have the option of operating all admin functions thanks to multiple administrators.

8. Have you entered the admin key incorrectly five times?

If you have mistyped your admin key five times, you can activate your customer number as follows:

1) An admin already exists in your company network
Send your company admin a connection request by contacting your company admin under Company network profile.

2) You are opening a new company network
In this case, please contact our support team at: https://info.allplan.com/en/contact

9. How can I join an existing company network?

To join a company network, you need your company's customer number. You can enter this in the relevant field when you register or under myProfile. The administrator of your company network must then confirm your membership. You can inform your administrator of your connection request by contacting your company administrator under Company network profile.

connect.allplan.com/admin/company-connection.html

10. Help in Allplan Connect

On the following page you will find help on Allplan Connect:

connect.allplan.com/help.html
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			Question:

I have renewed my license or purchased an additional option or additional licenses for a license server license. How can I update the license?


Answer:

If you have purchased an additional option, such as terrain, or additional licenses for a license server license, you have to update your license to include this new option.
To update a license
License for a stand-alone workstation:
	Open the 'License settings' dialog box: Services application -> Utilities -> License settings 
	Click License activationon the left. Then click the license you want to update.
	The 'Update license' button is no longer grayed out.
	Click Update license.


On the license server:
	Start the License Settingsprogram on the server.
	Click License activationon the left. Then click the license you want to update.
	The 'Update license' button is no longer grayed out.
	Click Update license.


Note:
Check the version of the license server. You can find detailed information on the version (Build-ID) at bottom left in the License Settings program.
Make sure the version of the license server you use is at least 1.614.x.x. If you cannot see the Build-ID, you work with an older license server. 
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