[Question] Allplan 2021-0-3 VS .pypsub konnte wegen falscher Versionsnummer nicht gelesen werden.


Guten Tag,

Ich habe mich schon etwas mit den Python-Parts sowie mit Visual-Scripting auseinandergesetzt und bin nun beim Versionswechsel auf ein Problem gestoßen.

Die Scripte wurden in Allplan 2020 erstellt und das erste mal getestet/genutzt.
Nach dem Update auf Allplan 2021 gibt der VS-Trace die Fehlermeldung aus, dass die pypsub Datei nicht gelesen werden konnte.
Als Begründung wird eine falsche Version des Scripts genannt.

Die Datei "NodeBlank.pypsub" wird jedoch richtig erkannt und kann in VS verwendet werden.
Im Code habe ich keinen Unterschied feststellen können.
Auch das Ändern der Version im Code von 1.0 auf 1.1 oder 2.0 hat nichts am Fehler geändert.

Die Fehlerausgabe sowie die beiden Scripte habe ich Angehängt.

Gruß
Joseph

Attachments (3)

Type: image/png
Downloaded 29 times
Size: 64,07 KiB
Type: image/png
Downloaded 18 times
Size: 45,54 KiB
Type: image/png
Downloaded 11 times
Size: 33,98 KiB
1 - 2 (2)
  • 1

Hallo Joseph,

nach Absprach mit DEV-Team liegt das Problem daran, dass der Name von eigenen Nodes einen Unterstrich "_" hat. Die Versionskontrolle in VS hat momentan die Schwierigkeit den Unterstrich richtig zu verarbeiten. Als Workaround würde ich vorschlagen den Unterstrich "_" durch den Bindestrich "-" zu ersetzen.

Wir werden aber dann diese Problem fixen.

VG
Xinling

Product Owner – Visual Scripting

1 - 2 (2)
  • 1

https://campus.allplan.com/ uses cookies  -  More information

Accept